Package: fonts-noto-unhinted
Version: 20171026-2
Severity: normal
Tags: upstream

Dear Maintainer,

I used the "Noto Sans Symbols" font last year (I think on Debian stretch, but 
I'm not sure) to generate png output using libmakick++. It worked fine for 
various arrow and mathematical symbols e.g.:
the integral symbol: ∫ (U+222B INTEGRAL)
rightwards double arrow: ⇒ (U+21D2 RIGHTWARDS DOUBLE ARROW)

I wanted to make some changes, and noticed that I now get empty rectangles in 
my output, where I had symbols before.

I tried using "gnome-thumbnail-font" and "font-manager" to search for these 
symbols, but was unable to find them.

I looked through the archive of fonts-noto on*. 
fonts-noto-unhinted_20161116-1_all.deb seems to contain all the symbols I was 
using in "NotoSansSymbols-Regular.ttf". The current symbols ttf 
(NotoSansSymbols-Regular & NotoSansSymbols2-Regular) don't seem to contain them.


I think this was broken by commit bc9353da6f625b7a47035de952c2e8fd9e3ae889 in I don't understand how google's 
noto-fonts is organized, but it seems that a number of useful symbols were 
dropped in this commit.

These are my installed noto fonts:
ii  fonts-noto-hinted                             20171026-2                    
      all          "No Tofu" font families with large Unicode coverage (hinted)
ii  fonts-noto-mono                               20171026-2                    
      all          "No Tofu" monospaced font family with large Unicode coverage
ii  fonts-noto-unhinted                           20171026-2                    
      all          "No Tofu" font families with large Unicode coverage 


-- Package-specific info:
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                             Version               Architecture         
ii  fontconfig                       2.12.6-0.1            amd64                
 generic font configuration library - support binaries
ii  libfreetype6:amd64               2.8.1-2               amd64                
 FreeType 2 font engine, shared library files
ii  libxft2:amd64                    2.3.2-1+b2            amd64                
 FreeType-based font drawing library for X

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.14.0-3-amd64 (SMP w/8 CPU cores)
Locale: LANG=de_DE.utf8, LC_CTYPE=de_DE.utf8 (charmap=UTF-8), 
LANGUAGE=de_DE.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

-- no debconf information

Reply via email to