Package: node-backbone
Version: 1.3.3~dfsg-3
Severity: normal

The dependencies for ‘node-backbone’ do not allow a Backbone
application to be built with Webpack.

$ dpkg --list webpack
ii  webpack        3.5.6-1      all          Packs CommonJs/AMD modules for the 

$ webpack --version

$ cat ./webpack.config.js
"use strict";
const path = require('path');
module.exports = {
    entry: './source/foo.js',
    output: {
        path: path.resolve(__dirname, 'dist'),
        filename: 'app.js',
    resolve: {
        modules: ['/usr/lib/nodejs', '.'],
    resolveLoader: {
        modules: ['/usr/lib/nodejs'],

$ cat ./source/foo.js
"use strict";
import 'backbone';

$ webpack --config webpack.config.js
Hash: a9597112585b9ca5fb40
Version: webpack 3.5.6
Time: 209ms
 Asset    Size  Chunks             Chunk Names
app.js  129 kB       0  [emitted]  main
   [0] ./source/foo.js 34 bytes {0} [built]
   [1] /usr/share/javascript/backbone/backbone.js 72.2 kB {0} [built]
   [2] (webpack)/buildin/global.js 488 bytes {0} [built]
   [3] /usr/share/javascript/underscore/underscore.js 52.9 kB {0} [built]

ERROR in /usr/share/javascript/backbone/backbone.js
Module not found: Error: Can't resolve 'jquery' in 
 @ /usr/share/javascript/backbone/backbone.js 17:4-21:6
 @ ./source/foo.js

So the Debian package dependencies are all satisfied, but these are
not sufficient for Webpack to resolve the Backbone dependencies.

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 4.14.0-3-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8) (ignored: LC_ALL 
set to en_AU.UTF-8), LANGUAGE=en_AU.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set 
to en_AU.UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages node-backbone depends on:
ii  libjs-backbone   1.3.3~dfsg-3
ii  node-underscore  1.8.3~dfsg-1
ii  nodejs           8.9.3~dfsg-12

node-backbone recommends no packages.

Versions of packages node-backbone suggests:
ii  libjs-jquery-lazyload  1.7.2-1

-- no debconf information

 \          “When we talk to God, we're praying. When God talks to us, |
  `\         we're schizophrenic.” —Jane Wagner, via Lily Tomlin, 1985 |
_o__)                                                                  |
Ben Finney <>

Attachment: signature.asc
Description: PGP signature

Reply via email to