Package: hy
Version: 0.12.1-2
Severity: normal

Dear Maintainer,

thanks for hy.

Since hy has the habit of breaking compatibility with each minor release,
i often find myself in the situation that i need to implement things
differently, depending on the current hy version (and while i work with Debian
packages, my users more often than not just fetch the latest hy via pip).

It seems that the packaged hy REPL doesn't know about it's own version number
(unlike a hy REPL installed via virtualenv).

Not having the hy-version available doesn't really help here.

E.g.

~~~
$ /usr/bin/hy
hy unknown using CPython(default) 3.6.4+ on Linux
=> (import hy)
=> (print hy.__version__)
'unknown'
=>
~~~

whereas with virtualenv:

~~~
$ virtualenv  -p python3 hyenv
$ ./hyenv/bin/pip install hy
$ ./hyenv/bin/hy
hy 0.14.0 using CPython(default) 3.6.4+ on Linux
=> (import hy)
=> (print hy.__version__)
0.14.0
~~~



-- System Information:
Debian Release: buster/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.14.0-3-amd64 (SMP w/8 CPU cores)
Locale: LANG=de_AT.utf8, LC_CTYPE=de_AT.utf8 (charmap=UTF-8), 
LANGUAGE=de_AT.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages hy depends on:
ii  python3-hy  0.12.1-2

hy recommends no packages.

hy suggests no packages.

-- no debconf information

Reply via email to