Package: lintian
Version: 2.5.79
Severity: normal


unnecessary-source-date-epoch-assignment is thrown for exim4, however

a) SOURCE_DATE_EPOCH is exported by since dpkg-dev 1.18.8
b) exim4 only build-depends on debhelper (>= 10), without an additional
   build-dependency on dpkg-dev ( >= 1.18.8)
c) debhelper 10 depends on dpkg (>= 1.16.2), dpkg-dev (>= 1.18.2~)

and therefore the build-depencies do not guarantee that dpkg-dev ( >=
1.18.8) is installed and the SOURCE_DATE_EPOCH assignment in
debian/rules is not superfluous.

Please only trigger the warning for packages with b-d on either
dpkg-dev ( >= 1.18.8) or debhelper (>= 10.10).

TIA, cu Andreas

cu Andreas

Reply via email to