Package: dosfstools
Version: 4.1-1
Severity: normal

Dear Maintainer,

Somehow the /boot partition of my Raspberry Pi got corrupted.

So I did try to fix it on the pi and this failed, because the dirty bit is not 
being re-set.
This bug is confirmed by some google findings.
So moved the SD-Card to a reader and did try to fix the FS on a AMD64 machine..

Same result:

# fsck.vfat -v -a -w /dev/sde1
fsck.fat 4.1 (2017-01-24)
Checking we can access the last sector of the filesystem
0x25: Dirty bit is set. Fs was not properly unmounted and some data may be 
 Automatically removing dirty bit.
Boot sector contents:
System ID "mkdosfs"
Media byte 0xf8 (hard disk)
       512 bytes per logical sector
      8192 bytes per cluster
        16 reserved sectors
First FAT starts at byte 8192 (sector 16)
         2 FATs, 16 bit entries
     16384 bytes per FAT (= 32 sectors)
Root directory starts at byte 40960 (sector 80)
       512 root directory entries
Data area starts at byte 57344 (sector 112)
      7161 data clusters (58662912 bytes)
63 sectors/track, 255 heads
         0 hidden sectors
    114688 sectors total
Reclaiming unconnected clusters.
Performing changes.
/dev/sde1: 81 files, 2546/7161 clusters

Upon re-running fsck.vat I get told the dirty bit is still on.

Did also try fsck.vat and fsck.msdos, same result.


-- System Information:
Debian Release: 9.3
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.14.0-3-amd64 (SMP w/4 CPU cores)
Locale: LANG=de_CH.UTF-8, LC_CTYPE=de_CH.UTF-8 (charmap=UTF-8), 
LANGUAGE=de_CH:de (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages dosfstools depends on:
ii  libc6     2.24-11+deb9u1
ii  libudev1  232-25+deb9u1

dosfstools recommends no packages.

dosfstools suggests no packages.

-- no debconf information

Reply via email to