Package: puppet
Version: 5.4.0-1
Severity: grave
Justification: renders package unusable

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?
   * What exactly did you do (or not do) that was effective (or
   * What was the outcome of this action?
   * What outcome did you expect instead?

*** End of the template - remove these template lines ***


My puppet environment broke after dist-upgrade of buster, changing puppet
related packages from 4.10.4-2 to 5.4.0-1. (date 2018-03-02)

All action from the clients that connect to the master (passenger mode)
fail with error:

Error: Could not retrieve catalog from remote server: Error 500 on SERVER: 
Server Error: undefined method `chain' for 

Trying a clean install of 5.4.0-1 results in the error below when trying to 
regenerate the certs:

puppet cert generate trillian --allow-dns-alt-names --debug --verbose
Traceback (most recent call last):
        4: from /usr/bin/puppet:5:in `<main>'
        3: from /usr/lib/ruby/vendor_ruby/puppet/util/command_line.rb:73:in 
        2: from /usr/lib/ruby/vendor_ruby/puppet/util/command_line.rb:126:in 
        1: from /usr/lib/ruby/vendor_ruby/puppet/gettext/config.rb:70:in 
`copy_default_translations': undefined method `chain' for 
#<FastGettext::TranslationRepository::Po:0x0257e0b0> (NoMethodError)

Reinstall was attempted to see if some config had changed, which it didn't.
Tested with personal configuration as well as clean setup.

At the moment puppet naster operations fail, regeneration of cert fails.
Can't test more, as I need a working puppet-master setup for this.

Did an update of all gems to see if this would help, no result. (debian
packages of all gems were up-to-date as well)

Downgrade to 4.10 is not possible, as it's not obtainable anumore, 4.8 in 
stable is to old as I need 4.9 or 4.10 due to functionality I've installed in 
my puppet code.

Would love tips on how to get this setup working or downgrade back to 4.10.4.
Looks like a dependency is missing in the 5.4 package.

-- System Information:
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux testing (buster)
Release:        testing
Codename:       buster
Architecture: armv7l

Kernel: Linux 4.9.59-v7+ (SMP w/4 CPU cores)
Locale: LANG=en_US.ISO8859-15, LC_CTYPE=en_US.ISO8859-15 (charmap=ISO-8859-15) 
(ignored: LC_ALL set to en_US.ISO8859-15), LANGUAGE=en_US.ISO8859-15 
(charmap=ISO-8859-15) (ignored: LC_ALL set to en_US.ISO8859-15)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages puppet depends on:
ii  adduser                     3.117
ii  facter                      3.10.0-3
ii  hiera                       3.2.0-2
ii  init-system-helpers         1.51
ii  lsb-base                    9.20161125+rpi1
ii  ruby                        1:2.5.0
ii  ruby-augeas                 1:0.5.0-3+b2
ii  ruby-deep-merge             1.1.1-1
ii  ruby-shadow                 2.5.0-1
ii  ruby2.0 [ruby-interpreter]
ii  ruby2.1 [ruby-interpreter]  2.1.5-2+deb8u3

Versions of packages puppet recommends:
ii  debconf-utils  1.5.66
ii  lsb-release    9.20161125+rpi1
pn  ruby-selinux   <none>

Versions of packages puppet suggests:
pn  ruby-hocon  <none>
pn  ruby-rrd    <none>

-- Configuration Files:
/etc/puppet/hiera.yaml changed [not included]
/etc/puppet/puppet.conf changed [not included]

-- no debconf information

-- gem list

*** LOCAL GEMS ***

bigdecimal (default: 1.3.4)
cmath (default: 1.0.0)
colored (1.2)
cri (2.10.1)
csv (default: 1.0.0)
date (default: 1.0.0)
deep_merge (1.1.1)
did_you_mean (1.0.0)
etc (default: 1.0.0)
faraday (0.9.2)
faraday_middleware (0.12.2)
fast_gettext (1.2.0)
fcntl (default: 1.0.0)
fiddle (default: 1.0.0)
fileutils (default: 1.0.2)
gdbm (default: 2.0.0)
gettext (3.2.4)
gettext-setup (0.7)
hiera (3.2.0)
io-console (default: 0.4.6)
ipaddr (default: 1.2.0)
json (default: 2.1.0)
locale (2.1.2)
log4r (1.1.10)
minitar (0.6.1)
minitest (5.10.3)
multi_json (1.12.1)
multipart-post (1.2.0)
net-telnet (0.1.1)
nokogiri (1.8.2)
openssl (default: 2.1.0)
pkg-config (1.2.9)
power_assert (0.2.7)
psych (default: 3.0.2)
puppet_forge (2.2.9)
r10k (2.6.2)
rack (1.6.4)
rake (12.3.0)
rdoc (default: 6.0.1)
rgen (0.8.0)
ruby-shadow (2.5.0)
safe_yaml (1.0.4)
scanf (default: 1.0.0)
sdbm (default: 1.0.0)
semantic_puppet (1.0.1)
soap4r-ruby1.9 (2.0.5)
stringio (default: 0.0.1)
strscan (default: 1.0.0)
systemu (2.6.5)
test-unit (3.2.5)
text (1.3.0)
webrick (default: 1.4.2)
zlib (default: 1.0.0)

Reply via email to