Package: xpra
Version: 2.1.3+dfsg-1
Severity: normal
Tags: patch
User: ubuntu-de...@lists.ubuntu.com
Usertags: origin-ubuntu ubuntu-patch bionic

I noticed that xpra.service had failed to start on my system.  The logs
said:

  ‚óŹ xpra.service - Xpra System Server
     Loaded: loaded (/lib/systemd/system/xpra.service; enabled; vendor preset: 
enabled)
     Active: failed (Result: exit-code) since Mon 2018-04-02 22:33:32 BST; 1 
day 14h ago
       Docs: https://xpra.org/trac/wiki/Service
             man:xpra
   Main PID: 6750 (code=exited, status=1/FAILURE)
  
  Apr 04 11:29:03 niejwein systemd[1]: /lib/systemd/system/xpra.service:10: 
Ignoring unknown escape sequences: "\"
  Apr 04 11:29:03 niejwein systemd[1]: /lib/systemd/system/xpra.service:11: 
Unknown lvalue '--ssl-cert' in section 'Service'

This was fixed upstream a while back
(https://www.xpra.org/trac/changeset/16837/xpra), so that seems worth
cherry-picking.

  * Remove trailing space that prevents line continuation.

diff -Nru xpra-2.1.3+dfsg/debian/patches/series 
xpra-2.1.3+dfsg/debian/patches/series
--- xpra-2.1.3+dfsg/debian/patches/series       2017-11-09 10:34:23.000000000 
+0000
+++ xpra-2.1.3+dfsg/debian/patches/series       2018-04-04 12:55:04.000000000 
+0100
@@ -13,3 +13,4 @@
 fix-systemd-service-path.patch
 fix-appstream-metadata-path.diff
 fix_spelling.diff
+systemd-trailing-space.patch
diff -Nru xpra-2.1.3+dfsg/debian/patches/systemd-trailing-space.patch 
xpra-2.1.3+dfsg/debian/patches/systemd-trailing-space.patch
--- xpra-2.1.3+dfsg/debian/patches/systemd-trailing-space.patch 1970-01-01 
01:00:00.000000000 +0100
+++ xpra-2.1.3+dfsg/debian/patches/systemd-trailing-space.patch 2018-04-04 
12:56:50.000000000 +0100
@@ -0,0 +1,17 @@
+Description: Remove trailing space that prevents line continuation
+Origin: upstream, https://www.xpra.org/trac/changeset/16837/xpra
+Last-Update: 2018-04-04
+
+Index: b/service/xpra-nosocketactivation.service
+===================================================================
+--- a/service/xpra-nosocketactivation.service
++++ b/service/xpra-nosocketactivation.service
+@@ -8,7 +8,7 @@
+ Type=simple
+ EnvironmentFile=-/etc/sysconfig/xpra
+ ExecStart=/usr/bin/xpra proxy :14500 --daemon=no \
+-    --bind-tcp=0.0.0.0:14500 --tcp-auth=${TCP_AUTH} \ 
++    --bind-tcp=0.0.0.0:14500 --tcp-auth=${TCP_AUTH} \
+     --ssl-cert=/etc/xpra/ssl-cert.pem --ssl=on \
+     --bind=/run/xpra/system --auth=${AUTH} --socket-dirs=/run/xpra 
--socket-permissions=666 \
+     --log-dir=/var/log --pidfile=/run/xpra.pid --debug=${DEBUG}

Thanks,

-- 
Colin Watson                                       [cjwat...@ubuntu.com]

Reply via email to