Package: mailman3
Version: 3.1.1-8
Severity: normal

i did "apt install dbconfig-no-thanks mailman3" and it produced this failure:

Setting up mailman3 (3.1.1-8) ...
dpkg: error processing package mailman3 (--configure):
 installed mailman3 package post-installation script subprocess returned error 
exit status 10

If i try to make it a bit more verbose, i get this failure (not very 
descriptive):

0 root@sid:~# bash -x /var/lib/dpkg/info/mailman3.postinst configure
+ set -e
+ . /usr/share/debconf/confmodule
++ '[' '!' '' ']'
++ PERL_DL_NONLAZY=1
++ export PERL_DL_NONLAZY
++ '[' '' ']'
++ exec /usr/share/debconf/frontend /var/lib/dpkg/info/mailman3.postinst 
configure
10 root@sid:~#

If i run the postinst script under strace, i see this underlying failure:

24505 write(1, "GET mailman3/database-type\n", 27 <unfinished ...>
24499 <... read resumed> "GET mailman3/database-type\n", 8192) = 27
24505 <... write resumed> )             = 27
24499 write(7, "10 mailman3/database-type doesn't exist\n", 40 <unfinished ...>


fwiw, i do not get these errors with dbconfig-sqlite3.  it seems to be 
related to dbconfig-no-thanks.

        --dkg


-- System Information:
Debian Release: buster/sid
  APT prefers unstable-debug
  APT policy: (500, 'unstable-debug'), (500, 'stable-updates'), (500, 
'unstable'), (500, 'stable'), (1, 'experimental-debug'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 4.15.0-2-amd64 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages mailman3 depends on:
ii  dbconfig-no-thanks          2.0.9
ii  debconf [debconf-2.0]       1.5.66
ii  logrotate                   3.11.0-0.1
ii  lsb-base                    9.20170808
ii  python3                     3.6.5-2
ii  python3-aiosmtpd            1.1-5
ii  python3-alembic             0.9.7-1
ii  python3-dnspython           1.15.0-1
ii  python3-falcon              1.0.0-2+b2
ii  python3-flufl.bounce        2.3-4
ii  python3-flufl.i18n          2.0.1-1
ii  python3-flufl.lock          3.2-1
ii  python3-lazr.config         2.2-1
ii  python3-passlib             1.7.1-1
ii  python3-psycopg2            2.7.4-1
ii  python3-public              0.5-1
ii  python3-requests            2.18.4-2
ii  python3-sqlalchemy          1.2.5+ds1-1
ii  python3-zope.component      4.3.0-1
ii  python3-zope.configuration  4.0.3-3
ii  python3-zope.event          4.2.0-1
ii  python3-zope.interface      4.3.2-1+b1
ii  ucf                         3.0038

Versions of packages mailman3 recommends:
pn  default-mta | mail-transport-agent  <none>
pn  lynx                                <none>

Versions of packages mailman3 suggests:
pn  mailman3-doc                                              <none>
pn  postgresql | default-mysql-server | virtual-mysql-server  <none>

-- debconf information:
  mailman3/init_service_failed:
  mailman3/config_hyperkitty:

Reply via email to