I have the same issue, this is what I've found so far:

- after plugging in the Arduino and starting the IDE, the status line reports 
the correct 
settings (board type and serial device selected in a previous session)

- just klicking on the 'Tools' menu throws the error message:
java.lang.NullPointerException thrown while loading gnu.io.RXTXCommDriver

- the user running the Arduino IDE is in the dialout group, I tried if chmod 
666 on the serial 
device would help but it didn't

- tried to send a sketch to the Arduino, this produced the following two lines  

java.lang.NullPointerException thrown while loading gnu.io.RXTXCommDriver
PORTS {} / {} => {}

then followed by:

processing.app.debug.RunnerException: Couldn’t find a Leonardo on the selected 
Check that you have the correct port selected.  If it is correct, try pressing 
the board's reset 
button after initiating the upload.
        at processing.app.Sketch.upload(Sketch.java:1671)
        at processing.app.Sketch.exportApplet(Sketch.java:1627)
        at processing.app.Sketch.exportApplet(Sketch.java:1599)
        at processing.app.Editor$DefaultExportHandler.run(Editor.java:2380)
        at java.base/java.lang.Thread.run(Thread.java:844)

-- System Information: 

Reply via email to