On 2018-04-09 20:41:55 +0200, Michael Biebl wrote:
> Not reproducible with a default GNOME / systemd as init installation.
> 
> Please investigate, if this issue is specific to sysvinit, xfce or some
> other custom modification (like special kernel parameters)

I'd say that it is specific to sysvinit. I have two other machines
with similar configuration but with systemd as the init system instead
of sysvinit, and I haven't seen any such problem on them.

The only other major difference between my machines is that the one
with sysvinit uses the nouveau driver instead of the nvidia one for
the two other machines, but I doubt very much that this has an
influence.

I've also checked the logs at startup. With systemd 238 (for which the
problem occurs):

[...]
Apr  9 15:33:17 ypig dbus-daemon[2930]: [system] Activating service 
name='org.freedesktop.login1' requested by ':1.4' (uid=0 pid=2987 
comm="/usr/sbin/lightdm ") (using servicehelper)
Apr  9 15:33:17 ypig dbus-daemon[2930]: [system] Activating service 
name='org.freedesktop.systemd1' requested by ':1.6' (uid=0 pid=3115 
comm="/lib/systemd/systemd-logind ") (using servicehelper)
Apr  9 15:33:17 ypig dbus-daemon[2930]: [system] Successfully activated service 
'org.freedesktop.login1'
Apr  9 15:33:18 ypig dbus-daemon[2930]: [system] Successfully activated service 
'org.freedesktop.systemd1'
Apr  9 15:33:25 ypig dbus-daemon[2930]: [system] Activating service 
name='org.freedesktop.ConsoleKit' requested by ':1.9' (uid=0 pid=3287 
comm="lightdm --session-child 17 20 ") (using servicehelper)
Apr  9 15:33:25 ypig dbus-daemon[2930]: [system] Activating service 
name='org.freedesktop.PolicyKit1' requested by ':1.12' (uid=0 pid=3291 
comm="/usr/sbin/console-kit-daemon --no-daemon ") (using servicehelper)
Apr  9 15:33:25 ypig polkitd[3358]: started daemon version 0.105 using 
authority implementation `local' version `0.105'
Apr  9 15:33:25 ypig dbus-daemon[2930]: [system] Successfully activated service 
'org.freedesktop.PolicyKit1'
Apr  9 15:33:25 ypig dbus-daemon[2930]: [system] Successfully activated service 
'org.freedesktop.ConsoleKit'
Apr  9 15:33:27 ypig dbus-daemon[3376]: [session uid=124 pid=3374] Activating 
service name='org.a11y.Bus' requested by ':1.0' (uid=124 pid=3369 
comm="/usr/sbin/lightdm-gtk-greeter ")
Apr  9 15:33:28 ypig dbus-daemon[3376]: [session uid=124 pid=3374] Successfully 
activated service 'org.a11y.Bus'
[...]

After downgrading to systemd 237:

[...]
Apr  9 15:45:28 ypig dbus-daemon[3024]: [system] Activating service 
name='org.freedesktop.login1' requested by ':1.2' (uid=0 pid=3059 
comm="/usr/sbin/lightdm ") (using servicehelper)
Apr  9 15:45:28 ypig dbus-daemon[3024]: [system] Activating service 
name='org.freedesktop.systemd1' requested by ':1.4' (uid=0 pid=3131 
comm="/lib/systemd/systemd-logind ") (using servicehelper)
Apr  9 15:45:28 ypig dbus-daemon[3024]: [system] Successfully activated service 
'org.freedesktop.login1'
Apr  9 15:45:29 ypig dbus-daemon[3024]: [system] Successfully activated service 
'org.freedesktop.systemd1'
Apr  9 15:45:40 ypig dbus-daemon[3315]: [session uid=124 pid=3313] Activating 
service name='org.a11y.Bus' requested by ':1.0' (uid=124 pid=3308 
comm="/usr/sbin/lightdm-gtk-greeter ")
Apr  9 15:45:40 ypig dbus-daemon[3315]: [session uid=124 pid=3313] Successfully 
activated service 'org.a11y.Bus'
[...]

I assume that the ConsoleKit one can see with systemd 238 is a
fallback due to some issue with login1.

I could try again with systemd 238 and look at the lightdm debug
logs (I no longer have them right now since I rebooted twice) to
see if there's any error.

-- 
Vincent Lefèvre <vinc...@vinc17.net> - Web: <https://www.vinc17.net/>
100% accessible validated (X)HTML - Blog: <https://www.vinc17.net/blog/>
Work: CR INRIA - computer arithmetic / AriC project (LIP, ENS-Lyon)

Reply via email to