Package: flite
Version: 2.1-release-1
Severity: normal
Tags: patch
User: debian-ri...@lists.debian.org
Usertags: riscv64

Hi,

We are in the process of bootstrapping a Debian port for the
riscv64 architecture (https://wiki.debian.org/RISC-V). It happens that
the config.guess/sub included in flite is too old to recognize this
system. flite uses dh, so this file is automatically updated before
running the configure script. Unfortunately flite also calls
config.guess during the clean target, causing the build to fail:

| ...
|  debian/rules clean
| dh clean
|    dh_auto_clean
|       make -j3 -O distclean
| make[1]: Entering directory '/<<PKGBUILDDIR>>'
| *** 
| *** Making default config file ***
| *** 
| checking build system type... ./config.guess: unable to guess system type
| 
| This script, last modified 2013-11-29, has failed to recognize
| the operating system you are using. It is advised that you
| download the most up to date version of the config scripts from
| 
|   
http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.guess;hb=HEAD
| and
|   
http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.sub;hb=HEAD
| 
| If the version you run (./config.guess) is already up to date, please
| send the following data and any information you think might be
| pertinent to <config-patc...@gnu.org> in order to provide the needed
| information to handle your system.
| 
| config.guess timestamp = 2013-11-29
| ...

The full build log is available there:

https://buildd.debian.org/status/fetch.php?pkg=flite&arch=riscv64&ver=2.1-release-1&stamp=1522978424&raw=0

The solution is to call dh_update_autotools_config in the clean target
before calling the make-distclean, like in the patch below. dh_clean will
then revert that change.

diff -Nru flite-2.1-release/debian/rules flite-2.1-release/debian/rules
--- flite-2.1-release/debian/rules      2018-01-03 21:44:36.000000000 +0100
+++ flite-2.1-release/debian/rules      2018-04-13 12:52:35.000000000 +0200
@@ -17,6 +17,10 @@
 AUDIO=oss
 endif
 
+override_dh_auto_clean:
+       dh_update_autotools_config
+       dh_auto_clean
+
 override_dh_auto_configure:
        dh_auto_configure -- --with-audio=$(AUDIO) \
                --with-vox=cmu_us_kal16 --enable-shared


Would it be possible to include it to the next upload?

Thanks,
Aurelien


-- System Information:
Debian Release: buster/sid
  APT prefers unreleased
  APT policy: (500, 'unreleased'), (500, 'unstable')
Architecture: riscv64

Kernel: Linux 4.15.0_riscv-linux-4.15_2b0aa1de4+ (SMP w/1 CPU core)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8), 
LANGUAGE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Reply via email to