Package: virtualbox
Version: 5.2.8-dfsg-10
Severity: normal

Dear Maintainer,

 Video capture feature doesn't work with virtualbox package in Debian.
 But it works with package upstream provides.

Works: 5.2.8 r121009 (Qt5.10.1)

Package: virtualbox-5.2
Version: 5.2.8-121009~Debian~stretch
Maintainer: Oracle Corporation <>                           

$ VBoxManage controlvm NetBSD videocap on
$ VBoxManage controlvm NetBSD videocap off
VBoxManage: error: Unable to start video capturing (VERR_ALREADY_EXISTS)
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component 
ConsoleWrap, interface IConsole, callee nsISupports                             
VBoxManage: error: Context: "COMSETTER(VideoCaptureEnabled)(FALSE)" at line 
1788 of file VBoxManageControlVM.cpp                                            
$ VBoxManage controlvm NetBSD videocap off

Not work: 5.2.8_Debian r120774

Package: virtualbox
Version: 5.2.8-dfsg-10
Maintainer: Debian Virtualbox Team 

$ VBoxManage controlvm NetBSD videocap off                                      
Oracle VM VirtualBox Command Line Management Interface Version 5.2.8_Debian     
(C) 2005-2018 Oracle Corporation                                                
All rights reserved.                                                            
VBoxManage controlvm        <uuid|vmname>                                       
                                           <password file>|-
                                           [--removeonsuspend <yes|no>]
                            removeencpassword <id>

Syntax error: Invalid parameter 'videocap'

 With debian packaged virtualbox, video capture feature seems to be

 I've tried 5.2.6-dfsg-1 and got same result. Under 5.2.4 does not work
 with current kernel (failed with building module), so not checked.

-- System Information:
Debian Release: buster/sid
  APT prefers unstable-debug
  APT policy: (500, 'unstable-debug'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 4.15.0-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=ja_JP.UTF-8, LC_CTYPE=ja_JP.UTF-8 (charmap=UTF-8), 
LANGUAGE=ja_JP.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages virtualbox depends on:
ii  adduser                               3.117
ii  iproute2                              4.15.0-3
ii  libc6                                 2.27-3
ii  libcurl3-gnutls                       7.58.0-2
ii  libdevmapper1.02.1                    2:1.02.145-4.1
ii  libgcc1                               1:8-20180414-1
ii  libgsoap-2.8.60                       2.8.60-2
ii  libpng16-16                           1.6.34-1
ii  libpython3.6                          3.6.5-3
ii  libsdl1.2debian                       1.2.15+dfsg2-0.1
ii  libssl1.1                             1.1.0h-2
ii  libstdc++6                            8-20180414-1
ii  libvncserver1                         0.9.11+dfsg-1
ii  libx11-6                              2:1.6.5-1
ii  libxcursor1                           1:1.1.15-1
ii  libxext6                              2:1.3.3-1+b2
ii  libxml2                               2.9.4+dfsg1-6.1
ii  libxmu6                               2:1.1.2-2
ii  libxt6                                1:1.1.5-1
ii  procps                                2:3.3.14-1
ii  python3                               3.6.5-3
ii  python3.6                             3.6.5-3
ii  virtualbox-dkms [virtualbox-modules]  5.2.8-dfsg-10
ii  zlib1g                                1:1.2.8.dfsg-5

Versions of packages virtualbox recommends:
ii  libgl1          1.0.0+git20180308-1
ii  libqt5core5a    5.10.1+dfsg-5
ii  libqt5opengl5   5.10.1+dfsg-5
ii  libqt5widgets5  5.10.1+dfsg-5
ii  virtualbox-qt   5.2.8-dfsg-10

Versions of packages virtualbox suggests:
pn  vde2                            <none>
pn  virtualbox-guest-additions-iso  <none>

-- no debconf information

Reply via email to