Package: thunderbird
Version: 1:60.0~b6-1
Severity: normal
Tags: upstream

Dear Maintainer,

I've noticed new DENIED message after recent pack of Sid updates, where
some new Mesa packages where received:

```
type=AVC msg=audit(1528914778.433:521): apparmor="DENIED" operation="open" 
profile="thunderbird" name="/home/vincas/.cache/mesa_shader_cache/index" 
pid=10212 comm="thunderbird" requested_mask="wrc" denied_mask="wrc" fsuid=1000 
ouid=1000
```

Breakpoint:

```
#0  0x00007f8f8600942e in __libc_open64 (file=0x7f8f84fc8370 
"/home/vincas/.cache/mesa_shader_cache/index", oflag=524354) at 
../sysdeps/unix/sysv/linux/open64.c:47
#1  0x00007f8f6ebeb4c1 in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#2  0x00007f8f6ed2db72 in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#3  0x00007f8f6ed5ca34 in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f8f6ecef304 in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f8f70975b47 in  () at /lib/x86_64-linux-gnu/libGLX_mesa.so.0
#6  0x00007f8f7094995e in  () at /lib/x86_64-linux-gnu/libGLX_mesa.so.0
#7  0x00007f8f70945134 in  () at /lib/x86_64-linux-gnu/libGLX_mesa.so.0
#8  0x00007f8f70945fb5 in  () at /lib/x86_64-linux-gnu/libGLX_mesa.so.0
#9  0x00007f8f77c5bb8f in  () at /usr/lib/thunderbird/libxul.so
#10 0x00007f8f77c5be57 in  () at /usr/lib/thunderbird/libxul.so
#11 0x00007f8f77c5161e in  () at /usr/lib/thunderbird/libxul.so
#12 0x00007f8f77c56d2a in  () at /usr/lib/thunderbird/libxul.so
#13 0x00007f8f77c575a2 in  () at /usr/lib/thunderbird/libxul.so
#14 0x00005652e6558d6c in  ()
#15 0x00005652e65584d9 in  ()
#16 0x00007f8f8512fa87 in __libc_start_main (main=0x5652e6558470, argc=1, 
argv=0x7ffe2c3b9828, init=<optimized out>, fini=<optimized out>, 
rtld_fini=<optimized out>, stack_end=0x7ffe2c3b9818) at ../csu/libc-start.c:310
#17 0x00005652e65587ea in _start ()

```

I guess some abstraction should be updated/created, as I got same error
with Firefox and Dragon Player local profiles.

-- System Information:
Debian Release: buster/sid
  APT prefers unstable-debug
  APT policy: (500, 'unstable-debug'), (500, 'unstable'), (1, 
'experimental-debug'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.16.0-2-amd64 (SMP w/8 CPU cores)
Locale: LANG=lt_LT.UTF-8, LC_CTYPE=lt_LT.UTF-8 (charmap=UTF-8), LANGUAGE=lt 
(charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages thunderbird depends on:
ii  debianutils               4.8.6
ii  fontconfig                2.13.0-5
ii  libatk1.0-0               2.28.1-1
ii  libc6                     2.27-3
ii  libcairo-gobject2         1.15.10-3
ii  libcairo2                 1.15.10-3
ii  libdbus-1-3               1.12.8-3
ii  libdbus-glib-1-2          0.110-2
ii  libevent-2.1-6            2.1.8-stable-4
ii  libffi6                   3.2.1-8
ii  libfontconfig1            2.13.0-5
ii  libfreetype6              2.8.1-2
ii  libfribidi0               0.19.7-2
ii  libgcc1                   1:8.1.0-5
ii  libgdk-pixbuf2.0-0        2.36.11-2
ii  libglib2.0-0              2.56.1-2
ii  libgtk-3-0                3.22.30-1
ii  libgtk2.0-0               2.24.32-1
ii  libhunspell-1.6-0         1.6.2-1+b1
ii  libjsoncpp1               1.7.4-3
ii  libnspr4                  2:4.19-3
ii  libnss3                   2:3.37.1-1
ii  libpango-1.0-0            1.42.1-1
ii  libpangocairo-1.0-0       1.42.1-1
ii  libpangoft2-1.0-0         1.42.1-1
ii  libsqlite3-0              3.24.0-1
ii  libstartup-notification0  0.12-5
ii  libstdc++6                8.1.0-5
ii  libvpx5                   1.7.0-3
ii  libx11-6                  2:1.6.5-1
ii  libx11-xcb1               2:1.6.5-1
ii  libxcb-shm0               1.13-1
ii  libxcb1                   1.13-1
ii  libxext6                  2:1.3.3-1+b2
ii  libxrender1               1:0.9.10-1
ii  libxt6                    1:1.1.5-1
ii  psmisc                    23.1-1+b1
ii  x11-utils                 7.7+4
ii  zlib1g                    1:1.2.11.dfsg-1

Versions of packages thunderbird recommends:
ii  hunspell-ar [hunspell-dictionary]     3.2-1
ii  hunspell-en-gb [hunspell-dictionary]  1:6.0.3-3
ii  hunspell-en-us [hunspell-dictionary]  1:2018.04.16-1
ii  hunspell-lt [hunspell-dictionary]     1:6.0.3-3
ii  lightning                             1:60.0~b6-1

Versions of packages thunderbird suggests:
ii  apparmor          2.13-1
pn  fonts-lyx         <none>
ii  libgssapi-krb5-2  1.16-2

-- Configuration Files:
/etc/apparmor.d/usr.bin.thunderbird changed [not included]

-- no debconf information

Reply via email to