Package: python3-pygpu,python3-theano

theano.gpuarray does not work because the currently packaged version of pygpu is too old for it.


Is there a reason for not packaging 0.7.x or have you just not got around to it? According to codesearch, theano is the only package using pygpu, so compatibility does not appear to be a blocker.

>>> import theano.gpuarray
ERROR (theano.gpuarray): Could not initialize pygpu, support disabled
Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/theano/gpuarray/__init__.py", line 227, in <module>
    use(config.device)
File "/usr/lib/python3/dist-packages/theano/gpuarray/__init__.py", line 214, in use
    init_dev(device, preallocate=preallocate)
File "/usr/lib/python3/dist-packages/theano/gpuarray/__init__.py", line 73, in init_dev
    pygpu_version.fullversion)
ValueError: Your installed version of pygpu(0.6.9) is too old, please upgrade to 0.7.0 or later (but below 0.8.0)

Reply via email to