On Sat, 2018-08-11 at 22:31 +0900, Norbert Preining wrote:

> How can I check this? I tried xlsfonts and it showed me the texgyre
> fonts.

I tried installing tex-gyre as well as some other xfonts-* packages and
none of them show up in the xlsfonts output for me. I guess existing
Xorg processes don't automatically reload fonts.

I created a new user and logged into an openbox session and xlsfonts
showed the new fonts (unifont and baekmuk) but not gyre fonts.
I got the same with a GNOME Wayland session with XWayland.

Can you try creating a new user and running xlsfonts there?

Do you maybe have the gyre fonts installed elsewhere on your system?

Does this command print anything for you?

find /usr/share/fonts/X11/ -name fonts.dir -print0 | xargs -0 grep -i gyre

Can you delete the /usr/share/fonts/X11/*/fonts.dir files, reinstall
tex-gyre/lmodern and all the xfonts-* packages you have installed?

BTW, it might be a good idea to move the fonts into an xfonts-gyre
package to match how other X11 fonts are packaged.

> So moving the dh_installxfonts call to below the loop would solve it,
> but I first want to know what you mean with "not registered properly".

Solely the update-fonts-* in postinst and dep on xfonts-utils.



Attachment: signature.asc
Description: This is a digitally signed message part

Reply via email to