On Tue, Nov 27, 2018 at 03:15:07PM +0800, Andrew Lee wrote:
> Package: bundler
> Version: 1.16.1-3
> Severity: normal
> 
> Dear Maintainer,
> 
> I'm preparing open-build-service 2.9 package for Debian. While that I
> got to update some build-deps and noticed that there is an issue in
> bundler package that the tests on `ruby-appraisal` reports:
> ```
> │ Run tests for ruby2.5 from debian/ruby-tests.rake
> │
> └──────────────────────────────────────────────────────────────────────────────┘
> 
> RUBYLIB=/build/ruby-appraisal-2.2.0/debian/ruby-appraisal/usr/lib/ruby/vendor_ruby:.
> GEM_PATH=debian/ruby-appraisal/usr/share/rubygems-integration/all:/var/lib/gems/2.5.0:/usr/lib/x86_64-linux-gnu/rubygems-integration/2.5.0:/usr/share/rubygems-integration/2.5.0:/usr/share/rubygems-integration/all
> ruby2.5 -S rake -f debian/ruby-tests.rake
> /usr/bin/ruby2.5 /usr/bin/rspec --pattern ./spec/\*\*/\*_spec.rb
> bin/bundle:104:in `load': cannot load such file --
> /usr/share/rubygems-integration/all/gems/bundler-1.16.1/exe/bundle
> (LoadError)
> ```
> 
> We noticed this has been addressed upstream:
>   https://github.com/bundler/bundler/issues/6537
> 
> And you can see, upstream said that it is fixed on September 18, and the
> current version in Debian archive is from July 23. So there is probably
> a need to be update.
> 
> If you agree, I may proceed a newer version(which one you prefer?) in
> salsa.d.o for you to review.

I just pushed a pending update I had locally; can you please test the
current version in git?

Attachment: signature.asc
Description: PGP signature

Reply via email to