Holger Wansing <hwans...@mailbox.org> wrote:
> Package: src:debian-installer
> This is a follow-up report on
> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=911705
> which reports that font for Gujarati is broken/missing in the current G-I.

A (probably not so short) summary of the situation:

With commit 
"Replace ttf-freefont-udeb by fonts-freefont-udeb as the former has been
removed from unstable (and thus testing)." under
things changed for fonts apparently.
Gujarati is no longer usable, all glyphs are replaced by TOFU placeholder

Jonas Smedegaard proposed to switch to noto-fonts as an alternative.
He uploaded a new version of that udeb to unstable just some days ago, thus
it is only in unstable ATM.
So I tried that and built a netboot-gtk image locally with this patch 
implemented and with the noto-fonts-unhinted-udeb as a localudeb:

diff --git a/build/pkg-lists/gtk-common b/build/pkg-lists/gtk-common
index 69bfbc2e2..930b2102e 100644
--- a/build/pkg-lists/gtk-common
+++ b/build/pkg-lists/gtk-common
@@ -21,6 +21,8 @@ fonts-telu-udeb
 # For Sinhala
+# Test for Gujarati

And this brings Gujarati back to the G-I.

That leads to the assumption, that the gu glyphs seem to be missing in the new 
fonts-freefont package.

I need to mention, that the above patch (adding another udeb to the build)
increases the netboot-gtk image (amd64) from 69 to 85 MB!
Therefore that's probably not an acceptable solution as it is.
But I think Jonas would be able move the relevant glyphs to another udeb maybe, 
so that we don't need the whole fonts-noto-unhinted-udeb in the build?

(BTW: as a pointer for the future: maybe it's worse to switch to the noto-fonts
packages completely?)

Some additional info:
In the first place, I made some more changings, in rootskel-gtk, like this:

diff --git a/src/usr/bin/gtk-set-font b/src/usr/bin/gtk-set-font
index 9e7cd89..769737d 100644
--- a/src/usr/bin/gtk-set-font
+++ b/src/usr/bin/gtk-set-font
@@ -1,4 +1,5 @@
 #! /bin/sh
+# Test: add gu for use with noto-fonts-unhinted-udeb
 set -e
@@ -41,6 +42,8 @@ case "$language" in
        FONT_NAME="Tibetan Machine Uni"
        FONT_SIZE=$(($FONT_SIZE + 2))
+    gu)
+       FONT_NAME="Noto Sans Gujarati"
+       FONT_SIZE=$(($FONT_SIZE + 2))
        FONT_NAME="VL Gothic"
@@ -75,7 +78,7 @@ case "$language" in
        FONT_NAME="AR PL ShanHeiSun Uni"
-    bn|gu|hi|ml|mr|ne)
+    bn|hi|ml|mr|ne)
        FONT_SIZE=$(($FONT_SIZE + 2))

I assumed this is needed, but as I learned this is of no effect:
I also tried with
        FONT_NAME="Noto Sans Gujarati UI"
        FONT_NAME="Noto Serif Gujarati"

but that has no effect, the used font seems to be always the same. 
Don't know what I'm doing wrong here.
However the result is the use of a reasonable Gujarati font AFAICS, so 
better than nothing.


Holger Wansing <hwans...@mailbox.org>
PGP-Finterprint: 496A C6E8 1442 4B34 8508  3529 59F1 87CA 156E B076

Reply via email to