Package: git Version: 1:2.19.2-1 Severity: wishlist Hi Jonathan. I use testing + experimental git because I'm too lazy to build my own & I want to test Debian's.
As of 1-2 weeks ago I can't anymore because: $ sudo apt install -t unstable git Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: git : Depends: libc6 (>= 2.28) but 2.27-8 is to be installed E: Unable to correct problems, you have held broken packages. Here's my preferences.d file: Explanation: Ævar likes being on the bleeding git edge Package: git git-doc git-svn git-email git-man Pin: release a=unstable Pin-Priority: 1001 Explanation: Now git depends on a later libpcre2 (in unstable, not testing) Package: libpcre2-dev libpcre2-8-0 libpcre2-16-0 libpcre2-32-0 libpcre2-posix0 Pin: release a=unstable Pin-Priority: 1001 I can "fix" this by adding "libc6" to that latter "Package" line, but then: $ sudo apt install -t unstable git Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed and are no longer required: [A huge list including X11 etc. and stuff I definitely use] Use 'sudo apt autoremove' to remove them. The following additional packages will be installed: git-man libc6 Suggested packages: git-daemon-run | git-daemon-sysvinit git-el git-email git-gui gitk gitweb git-cvs git-mediawiki git-svn locales The following packages will be REMOVED: [A huge list of stuff I definitely use, including build-essential] The following packages will be upgraded: git git-man libc6 WARNING: The following essential packages will be removed. This should NOT be done unless you know exactly what you are doing! libc-bin 3 upgraded, 0 newly installed, 77 to remove and 3 not upgraded. Need to get 10.1 MB of archives. After this operation, 488 MB disk space will be freed. You are about to do something potentially harmful. To continue type in the phrase 'Yes, do as I say!' ?] So basically in order to proceed I need to (it seems) pin my entire OS to unstable, since everything depends on libc6. If it's possible to build the package so it's >= 2.27-8 (in testing) instead of >= 2.28-2 that would be awesome. I suppose supporting 2.24-11+deb9u3 in stable would be too much of a ... stretch. -- System Information: Debian Release: buster/sid APT prefers testing APT policy: (1000, 'testing'), (500, 'stable-updates'), (400, 'stable'), (100, 'unstable'), (50, 'experimental') Architecture: amd64 (x86_64) Kernel: Linux 4.18.0-3-amd64 (SMP w/4 CPU cores) Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US.UTF-8 (charmap=UTF-8) Shell: /bin/sh linked to /bin/dash Init: systemd (via /run/systemd/system) LSM: AppArmor: enabled Versions of packages git depends on: ii git-man 1:2.19.2-1 ii libc6 2.27-8 ii libcurl3-gnutls 7.62.0-1 ii liberror-perl 0.17027-1 ii libexpat1 2.2.6-1 ii libpcre2-8-0 10.32-3 ii perl 5.28.1-1 ii zlib1g 1:1.2.11.dfsg-1 Versions of packages git recommends: ii less 487-0.1+b1 ii openssh-client [ssh-client] 1:7.9p1-4 ii patch 2.7.6-3 Versions of packages git suggests: ii gettext-base 0.19.8.1-9 pn git-cvs <none> pn git-daemon-run | git-daemon-sysvinit <none> ii git-doc 1:2.19.2-1 pn git-el <none> pn git-email <none> pn git-gui <none> pn git-mediawiki <none> pn git-svn <none> pn gitk <none> pn gitweb <none> -- no debconf information