Le lundi 11 février 2019 à 11:01 +0000, Simon McVittie a écrit :
> Control: reassign 922022 gnome-shell 3.30.2-3
> Control: tags 922022 + moreinfo
> 
> On Mon, 11 Feb 2019 at 11:43:21 +0100, Alexandre Belgrand wrote:
> > After upgrading my Debian SID today, firefox-esr and chromium both
> > fallback from a French AZERTY keyboard to a QWERTY keyboard.
> 
> This sounds like the same problem as #922020, which was filed against
> gnome-shell (although we don't know yet whether it is actually a
> gnome-shell bug - nothing keyboard-related changed in the recent
> upload)
> and reported as affecting anything that uses X11 via XWayland (but
> not
> native Wayland apps like gedit).

Thanks. I replied on #922020. You may close #922022 as a duplicate.

> What precisely do you mean by "not applied"? Does typing into Firefox
> and Chromium behave as though you were using a USA keyboard
> (shift+2 -> @, shift+3 -> #, etc.)  or does it have some other
> behaviour?
> 
> What is in your /etc/default/keyboard?

$ cat /etc/default/keyboard 
XKBLAYOUT=fr
BACKSPACE=guess

> 
> What does `gsettings list-recursively org.gnome.desktop.input-
> sources` say?

$ gsettings list-recursively org.gnome.desktop.input-sources
org.gnome.desktop.input-sources show-all-sources false
org.gnome.desktop.input-sources xkb-options @as []
org.gnome.desktop.input-sources per-window false
org.gnome.desktop.input-sources current uint32 0
org.gnome.desktop.input-sources mru-sources @a(ss) []
org.gnome.desktop.input-sources sources [('xkb', 'fr')]

> Are there any warnings in the systemd journal or syslog that look
> relevant?

The only things which caught my eyes were:
Feb 11 10:44:45 x230 chromium.desktop[1878]: libva error:
va_getDriverName() failed with unknown libva error,driver_name=(null)
Feb 11 10:44:45 x230 chromium.desktop[1878]:
[3404:3404:0211/104445.711419:ERROR:vaapi_wrapper.cc(324)] vaInitialize
failed: unknown libva error
Feb 11 10:44:45 x230 chromium.desktop[1878]:
[3404:3404:0211/104445.778206:ERROR:sandbox_linux.cc(364)]
InitializeSandbox() called with multiple threads in process gpu-
process.

> Have you restarted gnome-shell (logged out and back in) since
> upgrading?
> (I don't expect that this would make any difference, but whether you
> did or not is an important data point in trying to reproduce the
> bug.)

yes. Several reboots.

> Does downgrading gnome-shell to the version in testing resolve this
> for you?
> 
> Other packages that might be relevant include mutter,
> gnome-settings-daemon, and anything else that /var/log/apt mentions
> as
> having been upgraded around the same time as gnome-shell.

The problem happened after this upgrade :

Start-Date: 2019-02-11  09:35:53
Commandline: apt-get dist-upgrade
Requested-By: mario (1000)
Upgrade: libgcc-7-dev:amd64 (7.4.0-4, 7.4.0-5), libmpx2:amd64 (8.2.0-
19, 8.2.0-20), exim4-base:amd64 (4.92~RC5-2, 4.92~RC6-1), qtbase5-dev-
tools:amd64 (5.11.3+dfsg-4, 5.11.3+dfsg-5), libseccomp2:amd64 (2.3.3-3, 
2.3.3-4), libqt5test5:amd64 (5.11.3+dfsg-4, 5.11.3+dfsg-5), libobjc-8-
dev:amd64 (8.2.0-19, 8.2.0-20), qt5-gtk-platformtheme:amd64
(5.11.3+dfsg-4, 5.11.3+dfsg-5), lib32stdc++6:amd64 (8.2.0-19, 8.2.0-
20), libqt5opengl5-dev:amd64 (5.11.3+dfsg-4, 5.11.3+dfsg-5), base-
passwd:amd64 (3.5.45, 3.5.46), grub-common:amd64 (2.02+dfsg1-10,
2.02+dfsg1-11), libobjc4:amd64 (8.2.0-19, 8.2.0-20), cpp-7:amd64
(7.4.0-4, 7.4.0-5), cpp-8:amd64 (8.2.0-19, 8.2.0-20), gcc-8-base:amd64
(8.2.0-19, 8.2.0-20), python3-urllib3:amd64 (1.24-1, 1.24.1-1), qt5-
default:amd64 (5.11.3+dfsg-4, 5.11.3+dfsg-5), libitm1:amd64 (8.2.0-19,
8.2.0-20), libdvdread4:amd64 (6.0.0-1, 6.0.1-1), libqt5dbus5:amd64
(5.11.3+dfsg-4, 5.11.3+dfsg-5), libqt5sql5-sqlite:amd64 (5.11.3+dfsg-4, 
5.11.3+dfsg-5), gcc-7-base:amd64 (7.4.0-4, 7.4.0-5), runit-helper:amd64 
(2.8.4, 2.8.5), exim4-daemon-light:amd64 (4.92~RC5-2, 4.92~RC6-1),
libqt5widgets5:amd64 (5.11.3+dfsg-4, 5.11.3+dfsg-5), libzbar0:amd64
(0.10+doc-10.1+b4, 0.10+doc-11), grub2-common:amd64 (2.02+dfsg1-10,
2.02+dfsg1-11), libcilkrts5:amd64 (7.4.0-4, 7.4.0-5), cmake-data:amd64
(3.13.2-1, 3.13.4-1), libasan4:amd64 (7.4.0-4, 7.4.0-5), libasan5:amd64
(8.2.0-19, 8.2.0-20), libquadmath0:amd64 (8.2.0-19, 8.2.0-20),
libpipeline1:amd64 (1.5.1-1, 1.5.1-2), grub-pc:amd64 (2.02+dfsg1-10,
2.02+dfsg1-11), libqt5xml5:amd64 (5.11.3+dfsg-4, 5.11.3+dfsg-5),
installation-report:amd64 (2.69, 2.70), libqt5printsupport5:amd64
(5.11.3+dfsg-4, 5.11.3+dfsg-5), libgcc1:amd64 (1:8.2.0-19, 1:8.2.0-20), 
libqt5concurrent5:amd64 (5.11.3+dfsg-4, 5.11.3+dfsg-5), libstdc++-7-
dev:amd64 (7.4.0-4, 7.4.0-5), grub-pc-bin:amd64 (2.02+dfsg1-10,
2.02+dfsg1-11), lib32gcc1:amd64 (1:8.2.0-19, 1:8.2.0-20), libgcc-8-
dev:amd64 (8.2.0-19, 8.2.0-20), libqt5gui5:amd64 (5.11.3+dfsg-4,
5.11.3+dfsg-5), libtsan0:amd64 (8.2.0-19, 8.2.0-20), man-db:amd64
(2.8.5-1, 2.8.5-2), libubsan0:amd64 (7.4.0-4, 7.4.0-5), libubsan1:amd64
(8.2.0-19, 8.2.0-20), g++-7:amd64 (7.4.0-4, 7.4.0-5), g++-8:amd64
(8.2.0-19, 8.2.0-20), rcs:amd64 (5.9.4-4, 5.9.4-5), exim4-config:amd64
(4.92~RC5-2, 4.92~RC6-1), qt5-qmake:amd64 (5.11.3+dfsg-4, 5.11.3+dfsg-
5), libgfortran4:amd64 (7.4.0-4, 7.4.0-5), libgfortran5:amd64 (8.2.0-
19, 8.2.0-20), gcc-7:amd64 (7.4.0-4, 7.4.0-5), gcc-8:amd64 (8.2.0-19,
8.2.0-20), libobjc-7-dev:amd64 (7.4.0-4, 7.4.0-5), gfortran-8:amd64
(8.2.0-19, 8.2.0-20), python-urllib3:amd64 (1.24-1, 1.24.1-1),
liblsan0:amd64 (8.2.0-19, 8.2.0-20), libgomp1:amd64 (8.2.0-19, 8.2.0-
20), libqt5core5a:amd64 (5.11.3+dfsg-4, 5.11.3+dfsg-5), debhelper:amd64
(12, 12.1), binfmt-support:amd64 (2.2.0-1, 2.2.0-2), qtbase5-dev:amd64
(5.11.3+dfsg-4, 5.11.3+dfsg-5), qtbase5-doc:amd64 (5.11.3+dfsg-4,
5.11.3+dfsg-5), libqt5opengl5:amd64 (5.11.3+dfsg-4, 5.11.3+dfsg-5),
libgfortran-8-dev:amd64 (8.2.0-19, 8.2.0-20), cmake:amd64 (3.13.2-1,
3.13.4-1), libcapstone3:amd64 (3.0.5-3, 3.0.5-4), libatomic1:amd64
(8.2.0-19, 8.2.0-20), libqt5network5:amd64 (5.11.3+dfsg-4, 5.11.3+dfsg-
5), libcc1-0:amd64 (8.2.0-19, 8.2.0-20), libgphobos76:amd64 (8.2.0-19,
8.2.0-20), libstdc++6:amd64 (8.2.0-19, 8.2.0-20), qt5-qmake-bin:amd64
(5.11.3+dfsg-4, 5.11.3+dfsg-5), libstdc++-8-dev:amd64 (8.2.0-19, 8.2.0-
20), libqt5sql5:amd64 (5.11.3+dfsg-4, 5.11.3+dfsg-5), libqt5sql5-
mysql:amd64 (5.11.3+dfsg-4, 5.11.3+dfsg-5), liberror-perl:amd64
(0.17027-1, 0.17027-2)
End-Date: 2019-02-11  09:36:50

Reply via email to