Hi Sean,

Thanks a lot for the fast response!

Gr, Martijn

Op 11-02-2019 om 22:22 schreef Sean Whitton:
Hello Martijn,

On Mon 11 Feb 2019 at 03:26PM +01, Martijn de Gouw wrote:

Package: emacsen-common
Version: 3.0.4~bpo9+1
Severity: normal

--- Please enter the report below this line. ---
Hi,

After Debian 9.7 was released I started to dist-upgrade our machines,
but it started to remove all emacs packages. I traced this behaviour
back to the emacsen-common package in stretch-backports.

All emacs packages depend on emacsen-common one way or the other, but
the package in stretch-backports is conflicting with most of them:
emacs19, emacs20, emacs21-common, emacs22-common, emacs23-common,
emacs24-common, emacs25-common, xemacs21-support.

Since there are no other emacs packages in stretch-backports, besides
emacsen-common, I pinned the emacsen-common to version 2.0.8 as a
work-around.

This package shouldn't be in stretch-backports; it was a mistake.  I
have requested removal.

It is possible that there is something wrong with your apt config, as
dist-upgrade shouldn't have caused something like this to happen, but I
can't immediately see how it could have happened.


--
Martijn de Gouw
Designer
Prodrive Technologies
Mobile: +31 63 17 76 161
Phone:  +31 40 26 76 200

Reply via email to