Package: qemu-system
Version: 1:3.1+dfsg-4
Severity: normal

Dear Maintainer,

after upgrading to qemu 3.1 from stretch, I found that both linux and
windows guests, when using the qxl device, do not come back from deep
power save.

That is, when I run either a standard ubuntu 17.10 or windows 10 (with
qxl-dod driver), then by default they switch off the screen after a while,
which results in black screen in qemu, as expected.

If one moves the mouse or presses a key shortly after this, the screen comes 

If I let the systems idle for longer (say, half an hour), then they seem
to go into a deeper powersave, and pressing a key or moving the mouse does
NOT restore the screen - it stays black.

When the vm is in this state, I have not found a way to get the display
back, the only way that works is to quit qemu and start it again (meaning
boot the guest again in a new qemu instance, I have not tried to
suspend/resume a vm).

I have verified that mouse inputs and keypresses are registered correctly
by the guest in this state, so I assume it does try to switch on the
virtual monitor.

Since this happens with both linux and windows guests, this looks like a
bug in qemu's display code to me.

-- System Information:
Debian Release: 9.6
  APT prefers stable
  APT policy: (990, 'stable'), (500, 'unstable-debug'), (500, 'testing-debug'), 
(500, 'stable-updates'), (500, 'stable-debug'), (500, 'unstable'), (500, 
'testing'), (1, 'experimental-debug'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386, x32

Kernel: Linux 4.18.20-041820-generic (SMP w/8 CPU cores)
Locale: LANG=C, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=C (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages qemu-system depends on:
ii  qemu-system-arm    1:2.8+dfsg-6+deb9u5
ii  qemu-system-mips   1:2.8+dfsg-6+deb9u5
ii  qemu-system-misc   1:3.1+dfsg-2+b1
ii  qemu-system-ppc    1:2.8+dfsg-6+deb9u5
ii  qemu-system-sparc  1:2.8+dfsg-6+deb9u5
ii  qemu-system-x86    1:3.1+dfsg-2+b1

qemu-system recommends no packages.

qemu-system suggests no packages.

-- no debconf information

Reply via email to