Package: dee
Version: 1.2.7+17.10.20170616-4
Severity: minor
Tags: patch
User: ubuntu-de...@lists.ubuntu.com
Usertags: origin-ubuntu disco ubuntu-patch

Dear Kartik,

I've noticed that recent versions of gir1.2-dee-1.0 depend on the python
interpreter.  A dependency on python:any is autogenerated by dh-python, but
there is also a hard-coded dependency on python in debian/control.

Although dee ships .py files for both python2.7 and python3, I think it's
incorrect for the package to depend on python.  We want to ensure byte
compilation of the .py for any interpreters that *are* installed, but
/usr/lib/python2.7/dist-packages/gi/overrides/Dee.py is intended to
supplement use of dee *if* a user is using it with python - having the gir
should not imply that python is present on the system.

This matters to Ubuntu in particular because we are working towards dropping
support for python2 in the upcoming 20.04 LTS release.

I've therefore uploaded the attached patch to Ubuntu to avoid pulling in
either python or python3 as a dependency of gir1.2-dee-1.0.  Please consider
this patch for Debian as well.

Cheers,
-- 
Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
Ubuntu Developer                                   https://www.debian.org/
slanga...@ubuntu.com                                     vor...@debian.org
diff -Nru dee-1.2.7+17.10.20170616/debian/control 
dee-1.2.7+17.10.20170616/debian/control
--- dee-1.2.7+17.10.20170616/debian/control     2018-12-04 05:06:09.000000000 
+0100
+++ dee-1.2.7+17.10.20170616/debian/control     2019-02-18 10:15:48.000000000 
+0100
@@ -69,9 +69,7 @@
 Package: gir1.2-dee-1.0
 Section: introspection
 Architecture: any
-Depends: python,
-         python3,
-         ${gir:Depends},
+Depends: ${gir:Depends},
          ${misc:Depends},
          ${python3:Depends},
          ${python:Depends},
diff -Nru dee-1.2.7+17.10.20170616/debian/gir1.2-dee-1.0.lintian-overrides 
dee-1.2.7+17.10.20170616/debian/gir1.2-dee-1.0.lintian-overrides
--- dee-1.2.7+17.10.20170616/debian/gir1.2-dee-1.0.lintian-overrides    
1970-01-01 01:00:00.000000000 +0100
+++ dee-1.2.7+17.10.20170616/debian/gir1.2-dee-1.0.lintian-overrides    
2019-02-18 10:15:48.000000000 +0100
@@ -0,0 +1,2 @@
+# opportunistic python bindings, we should not pull in python for this
+gir1.2-dee-1.0: python-package-missing-depends-on-python
diff -Nru dee-1.2.7+17.10.20170616/debian/rules 
dee-1.2.7+17.10.20170616/debian/rules
--- dee-1.2.7+17.10.20170616/debian/rules       2018-11-24 12:56:41.000000000 
+0100
+++ dee-1.2.7+17.10.20170616/debian/rules       2019-02-18 10:15:48.000000000 
+0100
@@ -27,6 +27,10 @@
 override_dh_python3:
        dh_python3 debian/gir1.2-dee-1.0/usr/lib/python3
 
+override_dh_python2:
+       dh_python2
+       sed -i -e'/python:Depends/d' debian/gir1.2-dee-1.0.substvars 
+       
 override_dh_gencontrol:
        dh_girepository
        dh_gencontrol

Reply via email to