Package: cron
Version: 3.0pl1-132
Severity: normal

Dear Maintainer,

* What led up to the situation?

I upgraded to Buster from stretch and noticed that my cron jobs were running at 
~7:38 AM
instead of the time in my /etc/crontab. After some troubleshooting, I did 
reinstall by
installing from 9.7 media followed immediately by apt full-upgrade. The problem 
persisted.
I then did the same on a different system and found that the problem exists on 
this
system as well (total of two out of two systems that exhibit the problem).

* What exactly did you do (or not do) that was effective (or
ineffective)?

I tried the default setting of 6:25 AM ["25 6 * * *"] and a few other times
(e.g., 1:00 AM ["0 1 * * *"]). cron seems to ignore all entries and the jobs 
always
run at ~7:38 AM. date and hwclock agree on current time. /etc/timezone is 
America/New_York
which is correct for me. TZ is not set anywhere that I can find. 
/var/spool/cron/crontabs
is empty, so there should be no other/duplicate jobs causing confusion. Also, 
the recent
shift to DST in the US did not change the behavior.

I googled, searched stackoverflow and bug reports, and posted in the forums. It 
appears
that I am the only person to observe this behavior, so I feel like a stupid 
user and have
been reluctant to send a report. However, I can reproduce the behavior on 
different
systems from a clean install using the default configuration.

* What was the outcome of this action?

Nothing seems to resolve the problem.

* What outcome did you expect instead?

I expected the jobs in the system crontab to run at the specified time.

-- Package-specific info:
--- EDITOR:


--- /usr/bin/editor:
/bin/nano

--- /usr/bin/crontab:
-rwxr-sr-x 1 root crontab 43600 Feb 24 15:56 /usr/bin/crontab

--- /var/spool/cron:
drwxr-xr-x 3 root root 4096 Mar 1 20:51 /var/spool/cron

--- /var/spool/cron/crontabs:
drwx-wx--T 2 root crontab 4096 Oct 7 2017 /var/spool/cron/crontabs

--- /etc/cron.d:
drwxr-xr-x 2 root root 4096 Mar 7 20:02 /etc/cron.d

--- /etc/cron.daily:
drwxr-xr-x 2 root root 4096 Mar 12 17:19 /etc/cron.daily

--- /etc/cron.hourly:
drwxr-xr-x 2 root root 4096 Mar 7 20:02 /etc/cron.hourly

--- /etc/cron.monthly:
drwxr-xr-x 2 root root 4096 Mar 7 20:02 /etc/cron.monthly

--- /etc/cron.weekly:
drwxr-xr-x 2 root root 4096 Mar 12 17:19 /etc/cron.weekly


-- System Information:
Debian Release: buster/sid
APT prefers testing
APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-2-amd64 (SMP w/4 CPU cores)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_OOT_MODULE, 
TAINT_UNSIGNED_MODULE
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages cron depends on:
ii adduser 3.118
ii debianutils 4.8.6.1
ii init-system-helpers 1.56+nmu1
ii libc6 2.28-8
ii libpam-runtime 1.3.1-5
ii libpam0g 1.3.1-5
ii libselinux1 2.8-1+b1
ii lsb-base 10.2018112800
ii sensible-utils 0.0.12

Versions of packages cron recommends:
ii exim4-daemon-light [mail-transport-agent] 4.92-2

Versions of packages cron suggests:
ii anacron 2.3-27
pn checksecurity <none>
ii logrotate 3.14.0-4

Versions of packages cron is related to:
pn libnss-ldap <none>
pn libnss-ldapd <none>
pn libpam-ldap <none>
pn libpam-mount <none>
pn nis <none>
pn nscd <none>

-- no debconf information
Package: cron
Version: 3.0pl1-132
Severity: normal


Dear Maintainer,


   * What led up to the situation?


I upgraded to Buster from stretch and noticed that my cron jobs were running at 
~7:38 AM 
instead of the time in my /etc/crontab. After some troubleshooting, I did 
reinstall by 
installing from 9.7 media followed immediately by apt full-upgrade. The problem 
persisted. 
I then did the same on a different system and found that the problem exists on 
this 
system as well (total of two out of two systems that exhibit the problem).


   * What exactly did you do (or not do) that was effective (or
     ineffective)?


I tried the default setting of 6:25 AM ["25 6 * * *"] and a few other times 
(e.g., 1:00 AM ["0 1 * * *"]). cron seems to ignore all entries and the jobs 
always 
run at ~7:38 AM. date and hwclock agree on current time. /etc/timezone is 
America/New_York 
which is correct for me. TZ is not set anywhere that I can find. 
/var/spool/cron/crontabs 
is empty, so there should be no other/duplicate jobs causing confusion. Also, 
the recent
shift to DST in the US did not change the behavior.


I googled, searched stackoverflow and bug reports, and posted in the forums. It 
appears
that I am the only person to observe this behavior, so I feel like a stupid 
user and have 
been reluctant to send a report. However, I can reproduce the behavior on 
different 
systems from a clean install using the default configuration.


   * What was the outcome of this action?


Nothing seems to resolve the problem.


   * What outcome did you expect instead?


I expected the jobs in the system crontab to run at the specified time.


-- Package-specific info:
--- EDITOR:




--- /usr/bin/editor:
/bin/nano


--- /usr/bin/crontab:
-rwxr-sr-x 1 root crontab 43600 Feb 24 15:56 /usr/bin/crontab


--- /var/spool/cron:
drwxr-xr-x 3 root root 4096 Mar  1 20:51 /var/spool/cron


--- /var/spool/cron/crontabs:
drwx-wx--T 2 root crontab 4096 Oct  7  2017 /var/spool/cron/crontabs


--- /etc/cron.d:
drwxr-xr-x 2 root root 4096 Mar  7 20:02 /etc/cron.d


--- /etc/cron.daily:
drwxr-xr-x 2 root root 4096 Mar 12 17:19 /etc/cron.daily


--- /etc/cron.hourly:
drwxr-xr-x 2 root root 4096 Mar  7 20:02 /etc/cron.hourly


--- /etc/cron.monthly:
drwxr-xr-x 2 root root 4096 Mar  7 20:02 /etc/cron.monthly


--- /etc/cron.weekly:
drwxr-xr-x 2 root root 4096 Mar 12 17:19 /etc/cron.weekly




-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)


Kernel: Linux 4.19.0-2-amd64 (SMP w/4 CPU cores)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_OOT_MODULE, 
TAINT_UNSIGNED_MODULE
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled


Versions of packages cron depends on:
ii  adduser              3.118
ii  debianutils          4.8.6.1
ii  init-system-helpers  1.56+nmu1
ii  libc6                2.28-8
ii  libpam-runtime       1.3.1-5
ii  libpam0g             1.3.1-5
ii  libselinux1          2.8-1+b1
ii  lsb-base             10.2018112800
ii  sensible-utils       0.0.12


Versions of packages cron recommends:
ii  exim4-daemon-light [mail-transport-agent]  4.92-2


Versions of packages cron suggests:
ii  anacron        2.3-27
pn  checksecurity  <none>
ii  logrotate      3.14.0-4


Versions of packages cron is related to:
pn  libnss-ldap   <none>
pn  libnss-ldapd  <none>
pn  libpam-ldap   <none>
pn  libpam-mount  <none>
pn  nis           <none>
pn  nscd          <none>


-- no debconf information

Reply via email to