Hi,

On Thu, Jun 13, 2019 at 12:13:30AM +0900, Vincent Lefevre wrote:
> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=930430 contains:
> 
> "Package: libasan5; Maintainer for libasan5 is Debian GCC Maintainers
> <debian-...@lists.debian.org>; Source for libasan5 is src:gcc-9 (PTS,
> buildd, popcon).
> [...]
> Found in version gcc-8/8.3.0-7"
> 
> The "src:gcc-9" is incorrect, as the source for libasan5 is gcc-8
> (at least for the reported version), not gcc-9. The bug should
> appear on
> 
>   https://bugs.debian.org/cgi-bin/pkgreport.cgi?src=gcc-8
> 
> not on
> 
>   https://bugs.debian.org/cgi-bin/pkgreport.cgi?src=gcc-9

The BTS looks at the newest know version to decide the source <-> binary
mapping. If the mapping is different in unstable and experimental, the one
from experimental will be used (because the version is higher). That's what's
happening here (libasan5 is built by gcc-9 in experimental).

It might be better to prefer the mapping from unstable over the one from
experimental, even though that will be wrong in some other cases. I don't know
if it's realistic to have the mapping depend on the version information in the
bug.

Ivo

Reply via email to