Package: libreswan
Version: 3.27-6
Severity: normal

Dear Maintainer,

The libreswan binary package has a strict dependency on systemd; is it
necessary? It makes libreswan painful to install in containers...

Would it be possible to drop the dependency?

Thanks,

Stephen


-- System Information:
Debian Release: 10.0
  APT prefers stable-debug
  APT policy: (500, 'stable-debug'), (500, 'stable'), (100, 'unstable-debug'), 
(100, 'testing-debug'), (100, 'unstable'), (100, 'testing'), (1, 
'experimental-debug'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.19.0-5-amd64 (SMP w/8 CPU cores)
Kernel taint flags: TAINT_UNSIGNED_MODULE
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages libreswan depends on:
ii  bind9-host [host]        1:9.11.5.P4+dfsg-5.1
ii  bsdmainutils             11.1.2+b1
ii  debconf [debconf-2.0]    1.5.71
ii  dns-root-data            2019031302
ii  iproute2                 4.20.0-2
ii  iptables                 1.8.2-4
ii  libaudit1                1:2.8.4-3
ii  libc6                    2.28-10
ii  libcap-ng0               0.7.9-2
pn  libcurl3-nss             <none>
ii  libevent-2.1-6           2.1.8-stable-4
ii  libevent-pthreads-2.1-6  2.1.8-stable-4
ii  libldap-2.4-2            2.4.47+dfsg-3
ii  libldns2                 1.7.0-4
ii  libnspr4                 2:4.20-1
ii  libnss3                  2:3.42.1-1
ii  libnss3-tools            2:3.42.1-1
ii  libpam0g                 1.3.1-5
ii  libselinux1              2.8-1+b1
ii  libsystemd0              241-5
ii  libunbound8              1.9.0-2
ii  systemd                  241-5

Versions of packages libreswan recommends:
ii  python3  3.7.3-1

libreswan suggests no packages.

Reply via email to