Package: git-all
Version: 1:2.20.1-2
Severity: important

Dear Maintainer,

I did a fresh install of Debian Stable using the 
firmware-10.0.0-amd64-netinst.iso image and installed the following tasks: 
Debian desktop environment, XFCE, print server and standard system utilities.  
After this I ran a script which installed my usual packages.  For reference 
these were:
PACKAGELIST="emacs texlive texlive-latex-extra texlive-fonts-extra 
texlive-science texlive-games perl-tk latexmk auto-multiple-choice 
auto-multiple-choice-doc auctex psutils pstoedit pdftk pdfchain asymptote 
mkdocs mkdocs-doc elpa-markdown-mode xfig xfig-doc gsfonts-x11 fig2ps 
imagemagick inkscape krita blender build-essential glibc-doc git-all 
jupyter-core jupyter-notebook python3-widgetsnbextension jupyter-nbconvert  
python-notebook-doc python3-seaborn texlive-xetex python3-plotly python3-numpy 
python-numpy-doc python3-scipy python-scipy-doc idle3 python3-matplotlib 
python3-matplotlib-venn python-matplotlib-doc python3-mpmath python-mpmath-doc 
python3-gmpy2 python3-sympy python3-sympy-doc ipython3 python-ipython-doc 
wxmaxima evince sshfs sudo audacious gnome-sound-recorder simple-scan 
youtube-dl gnome-system-tools unattended-upgrades xournal deja-dup thunderbird 
locate xinput galculator obs-studio gigolo"
After this was complete my networking and the lightdm window manager were no 
longer present.  Looking at the apt log showed that my apt -y autoinstall of 
git-all had caused the removal of the task-xfce-desktop package, the 
network-manager the lightdm display manager as well as other core packages. 
This was obviously unexpected.

Next I reinstalled Debian as above without the git-all package and tried to 
install the various dependencies of git-all to see what was going on.  Looking 
at the dependencies of git-all shows that it recommends git-daemon-run or 
git-daemon-sysvinit.  It turns out that the  git-daemon-run package is the one 
which appears to require the removal of the core packages above if you try to 
install it after a fresh install.

The upshot is that because the default Debian install method is to install 
recommends and because git-all recommends git-daemon-run which in turn does not 
play nicely with the basic XFCE installation described above the system becomes 
broken. My suggestion would be to do one of the following:

1) Fix the git-daemon-run package or its dependency which is causing this.  
This appears to be new behaviour in Debian 10 as it worked before in 9.
2) Make the default recommend git-daemon-sysvinit which at least does not cause 
this problem.
3) Make these recommended packages suggested only.

Thanks for your attention to this.

-- System Information:
Debian Release: 10.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-5-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_CA.UTF-8, LC_CTYPE=en_CA.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_CA:en (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages git-all depends on:
ii  git            1:2.20.1-2
pn  git-cvs        <none>
ii  git-doc        1:2.20.1-2
pn  git-el         <none>
pn  git-email      <none>
ii  git-gui        1:2.20.1-2
pn  git-mediawiki  <none>
pn  git-svn        <none>
ii  gitk           1:2.20.1-2
pn  gitweb         <none>

Versions of packages git-all recommends:
pn  git-daemon-run | git-daemon-sysvinit  <none>

git-all suggests no packages.

Reply via email to