Package: lintian,dh-python

please add an lintian warning/error for packages (b-)depending on python or
using the unversioned python shebang.

Not sure if this should be one or two different lintian warnings or errors.  We
definitely want to drop the python/python-dev binary packages, and not shipping
/usr/bin/python for bullseye.  Packages should either be using python3
(preferred), or use the python2.7 or python2 shebang or (b-)dependencies.

Maybe start with a warning, and raise that to an error later in the release 
cycle.

The description should mention that conversion to python3 is the preferred
solution, followed by removal of python2 stuff from the archive, and only if we
have to keep the python2 stuff, then the unversioned python names have to be
avoided.

Reply via email to