Hi,

Good question. They are being removed from bullseye; there are still some (2) packages that use grib-api rather than its replacement eccodes.

They need to be rebuilt to use eccodes before grib-api can be safely removed. This is happening presently.

Alastairx

On 11/09/2019 23:18, Fabrice Meyer wrote:
Hi,

Thanks for the answer, as I'm quite new into bug reporting, I also
reported the same bug for libgrib-api0 (so you want close one).

I wonder why these libraries appears in bullseye as they are, as you
say, obsolete. Is there an explanation (just curiosity)? And if the
purpose of theses packages is to achieve a kind of compatibility with
old software, shouldn't they be supported at list in the distribution?
Again just curiosity for learning purpose, you don't have to reply to this.

Thanks again for all the work you achieve(d).

On Wed, 11 Sep 2019 15:03:35 +0100 Alastair McKinstry
<alastair.mckins...@sceal.ie> wrote:

Hi,

libgrib-api-tools is obsolete, and should be replaced with
libeccodes-tools.
libgrib-api-tools will be removed from Debian soon,

regards

Alastair

On 11/09/2019 13:15, Fabrice Meyer wrote:
Package: libgrib-api-tools
Version: 1.28.0-2
Severity: normal

Dear Maintainer,

grib_set lead to a missing file error while calling it with -s and
-w. The missing file is /usr/share/grib_api/definitions/boot.def but the
whole directory /usr/share/grib_api is also missing.
This could be solved by adding a link to /usr/share/eccodes/ which
come with libeccodes-data package, already included in libgrib-api-tools
d├ępendencies.
An other solution would be to use libeccodes-tools package instead
of libgrib-api-tools
I hope this will be usefull to someone

-- System Information:
Debian Release: 10.1
APT prefers stable-updates
APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-6-amd64 (SMP w/1 CPU core)
Kernel taint flags: TAINT_CRAP
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8),
LANGUAGE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages libgrib-api-tools depends on:
ii libc6 2.28-10
ii libeccodes-data 2.12.0-1
ii libgrib-api0 1.28.0-2
ii libnetcdf13 1:4.6.2-1

Versions of packages libgrib-api-tools recommends:
ii python-gribapi 1.28.0-2
ii python3-gribapi 1.28.0-2

libgrib-api-tools suggests no packages.

-- no debconf information
--
Alastair McKinstry, email: alast...@sceal.ie, matrix:
@alastair:sceal.ie, phone: 087-6847928
Green Party Councillor, Galway County Council



--
Alastair McKinstry, email: alast...@sceal.ie, matrix: @alastair:sceal.ie, 
phone: 087-6847928
Green Party Councillor, Galway County Council

Reply via email to