Dear Karlheinz, wrote:
> mutt 1.10.1-2 fails to sign, encrypt and verfiy S/MIME E-Mail messages.
> "#840850 mutt: Mutt can't find S/MIME key to sign messages" suggests to
> _unset crypt_use_gpgme_ in muttrc, but this changes nothing.

Really nothing?

For me it definitely changed the error message from IIRC "secret key
`fea09d36.0' not found: End of file?" to something like "Can't open
file /home/abe/.smime/certificates/0x91178E78F3FD43F14391244E67B3FB6257AB0136:
file not found" — at least a clearly a different error message despite
again about a key not being found.

I first solved this by maing a symlink from the file name in the new
error message to the file with the old certificate:

$ cd ~/.smime/certificates/
$ ln -vis fea09d36.0 0x91178E78F3FD43F14391244E67B3FB6257AB0136

This helped to find the certificate, but the verification of the sent
mails now failed because the (in my and most cases necessary)
intermediate certificate was no more included.

So I removed the the symlink again and created a new file named
0x91178E78F3FD43F14391244E67B3FB6257AB0136 containing my certificate
and the intermediate certificate concatenated:

$ cat fea09d36.0 cfb2f36d.0 > 0x91178E78F3FD43F14391244E67B3FB6257AB0136

>From then on, my mutt was able to sent S/MIME signed mails again.
(Haven't tried S/MIME-encryption yet, though.)

The only thing I so far didn't figure out is, what kind of hashes were
and are now used for looking for the certificate files.

> thx fer ani hlp, vy 73 de Karlheinz, DK8KK

HTH. (Sorry, still no AFu speak here. :-)

And JFTR of #840850: The bug has been initially reported by a version
older than in Stretch, but I never had this issue in Stretch, just
after upgrading from Stretch (1.7.2-1+deb9u1) to Buster (1.10.1-2.1 —
mutt, not neomutt).

                Regards, Axel
 ,''`.  |  Axel Beckert <>,
: :' :  |  Debian Developer, Admin
`. `'   |  4096R: 2517 B724 C5F6 CA99 5329  6E61 2FF9 CD59 6126 16B5
  `-    |  1024D: F067 EA27 26B9 C3FC 1486  202E C09E 1D89 9593 0EDE

Reply via email to