Package: licensecheck
Version: 3.0.39-1
Severity: normal

Dear Maintainer,

   * What led up to the situation?

Running licensecheck on scikit-learn package:

$ licensecheck --copyright sklearn/manifold/_t_sne.py
sklearn/manifold/_t_sne.py: BSD (unspecified)
  [Copyright: 2014]

Even though this file is BDS-3-clause:

$ grep -C 3 BSD sklearn/manifold/_t_sne.py
# Author: Alexander Fabisch  -- <afabi...@informatik.uni-bremen.de>
# Author: Christopher Moody <chrisemo...@gmail.com>
# Author: Nick Travers <ni...@squareup.com>
# License: BSD 3 clause (C) 2014

# This is the exact and Barnes-Hut t-SNE implementation. There are other
# modifications of the algorithm:

   * What outcome did you expect instead?

I expected licensecheck to detect a "BSD-3-clause" license instead of
BSD unspecified.

All the best


Dod


-- System Information:
Debian Release: bullseye/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 
'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.4.0-2-amd64 (SMP w/8 CPU cores)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_WARN, TAINT_OOT_MODULE, 
TAINT_UNSIGNED_MODULE
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_US:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages licensecheck depends on:
ii  libgetopt-long-descriptive-perl        0.104-1
ii  liblog-any-adapter-screen-perl         0.140-1
ii  liblog-any-perl                        1.707-1
ii  libmoo-perl                            2.003006-1
ii  libnamespace-clean-perl                0.27-1
ii  libpath-iterator-rule-perl             1.014-1
ii  libpath-tiny-perl                      0.108-1
ii  libpod-constants-perl                  0.19-1
ii  libre-engine-re2-perl                  0.13-4+b1
ii  libregexp-pattern-license-perl         3.1.99-1
ii  libregexp-pattern-perl                 0.2.11-1
ii  libscalar-list-utils-perl              1:1.53-1
ii  libsort-key-perl                       1.33-2+b2
ii  libstrictures-perl                     2.000006-1
ii  libstring-copyright-perl               0.003006-1
ii  libstring-escape-perl                  2010.002-2
ii  libtry-tiny-perl                       0.30-1
ii  perl                                   5.30.0-9
ii  perl-base [libscalar-list-utils-perl]  5.30.0-9

licensecheck recommends no packages.

Versions of packages licensecheck suggests:
ii  bash-completion  1:2.9-1

-- no debconf information

Reply via email to