Package: linux-image-amd64
Severity: normal

Dear maintainer,

package linux-image-amd64 seems to have an outdated dependency. shows

dep: linux-image-5.4.0-0.bpo.2-amd64 (= 5.4.8-1~bpo10+1) shows

dep: linux-headers-5.4.0-0.bpo.3-amd64 (= 5.4.13-1~bpo10+1)

bpo.2 vs bpo.3

I am under the assumption that dependency version of linux-image-amd64
should match dependency version of linux-headers-amd64. In comparsion to
buster (non-backports) the version matches. Kindly let me know if that
is an unreasonable assumption.

Bumped into this issue by running:

sudo apt-get -t buster-backports install linux-image-$(dpkg
--print-architecture) linux-headers-$(dpkg --print-architecture)

and then having DKMS report:

Error! Your kernel headers for kernel 5.4.0-0.bpo.2-amd64 cannot be found.
Please install the linux-headers-5.4.0-0.bpo.2-amd64 package,
or use the --kernelsourcedir option to tell DKMS where it's located

Which was unexpected.


Reply via email to