Le 04/03/2020 à 18:52, Mattia Rizzolo a écrit :
> On Wed, Mar 04, 2020 at 11:06:00PM +0530, Pirate Praveen wrote:
>> That is not correct. Xavier (yadd) proposed 3 solutions already. Hope he 
>> will share the relevant proposals.
> 
> Yes, the current one was proposed by him, as well as the one I linked
> below…
> I'm actually defending his work here :P

Hi and thanks ;-)

In next devscripts MR 178, I'm going to propose a complement to
"checksum" option to reduce long version:
 * new line option: ctype which gives the type of component (nodejs for
   now)
 * if this ctype exists, uscan reads package.json to find current
   component version

Tested with success with node-mongodb (both checksum and ctype), package
is up to date but a component changed. Current version is
3.5.5+~cs11.12.18-1, uscan detects change:

  $ uscan --report
  uscan: Newest version of bson on remote site is 1.1.4, local version
         is 1.1.3
  uscan.pl:    => Newer package available from
        https://registry.npmjs.org/bson/-/bson-1.1.4.tgz

Part of DEHS output (checksum changed well):

  <package>node-mongodb</package>
  <debian-uversion>3.5.5+~cs11.12.18</debian-uversion>
  <debian-mangled-uversion>3.5.5+~cs11.12.18</debian-mangled-uversion>
  <upstream-version>3.5.5+~cs11.12.19</upstream-version>


Try a download:

  $ uscan
  uscan.pl:    => Newer package available from
    https://github.com/mongodb/node-mongodb-native/archive/v3.5.5.tar.gz
  uscan.pl: Newest version of bson on remote site is 1.1.4,
    local version is 0
    (mangled local version is 1.1.3)
  # One change detected, all will be downloaded:
  uscan.pl:    => Newer package available from
        https://registry.npmjs.org/bson/-/bson-1.1.4.tgz
  Successfully symlinked ../node-mongodb-native-3.5.5.tar.gz to
    ../node-mongodb_3.5.5.orig.tar.gz.
  Successfully repacked ../mongodb-core-3.2.7.tgz as
    ../node-mongodb_3.2.7.orig-mongodb-core.tar.gz.
  Successfully repacked ../require_optional-1.0.1.tgz as
   ../node-mongodb_1.0.1.orig-requireoptional.tar.gz.
  Successfully repacked ../bson-1.1.4.tgz as
   ../node-mongodb_1.1.4.orig-bson.tar.gz.
  Successfully repacked ../denque-1.4.1.tgz as
   ../node-mongodb_1.4.1.orig-denque.tar.gz.
  Successfully repacked ../node-saslprep-1.0.3.tar.gz as
   ../node-mongodb_1.0.3.orig-saslprep.tar.gz.
  Successfully repacked ../node-sparse-bitfield-3.0.3.tar.gz as
   ../node-mongodb_3.0.3.orig-sparse-bitfield.tar.gz.
  Successfully repacked ../node-memory-pager-1.5.0.tar.gz as
   ../node-mongodb_1.5.0.orig-memory-pager.tar.gz.
  mv ../node-mongodb_3.5.5.orig.tar.gz to
    ../node-mongodb_3.5.5+~cs11.12.19.orig.tar.gz
  mv ../node-mongodb_3.2.7.orig-mongodb-core.tar.gz to
    ../node-mongodb_3.5.5+~cs11.12.19.orig-mongodb-core.tar.gz
  mv ../node-mongodb_1.0.1.orig-requireoptional.tar.gz to
    ../node-mongodb_3.5.5+~cs11.12.19.orig-requireoptional.tar.gz
  mv ../node-mongodb_1.1.4.orig-bson.tar.gz to
    ../node-mongodb_3.5.5+~cs11.12.19.orig-bson.tar.gz
  mv ../node-mongodb_1.4.1.orig-denque.tar.gz to
    ../node-mongodb_3.5.5+~cs11.12.19.orig-denque.tar.gz
  mv ../node-mongodb_1.0.3.orig-saslprep.tar.gz to
    ../node-mongodb_3.5.5+~cs11.12.19.orig-saslprep.tar.gz
  mv ../node-mongodb_3.0.3.orig-sparse-bitfield.tar.gz to
    ../node-mongodb_3.5.5+~cs11.12.19.orig-sparse-bitfield.tar.gz
  mv ../node-mongodb_1.5.0.orig-memory-pager.tar.gz to
    ../node-mongodb_3.5.5+~cs11.12.19.orig-memory-pager.tar.gz
  uscan.pl warn: Checksum ref:
     3.2.7+~1.0.1+~1.1.4+~1.4.1+~1.0.3+~3.0.3+~1.5.0

@mattia:

I didn't write tests for "ctype" for now, it depends if you accept both
MR or only one. I'll write them later.

Cheers,
Xavier

Reply via email to