Package: util-linux
Version: 2.34-0.1ubuntu9
Severity: important

Dear Maintainer,

I am trying to package bootiso <>, which
depends on util-linux >= 2.26 and requires the "column" command and its
numerous features, specifically -d, -N and -W flags.

However, since the bsdmainutils "column" is used instead, this dependency
cannot be honored for debian. This is a huge, blocking problem to
properly ship bootiso utility. Luckuly, being upstream author I can
write some hard-coded checks to control supported flags. But the general
idea that one author cannot rely on the presence of appropriate versions
of utilities as central to GNU/Linux as those shipped in "util-linux" is
troublesome. The rule responsible for disabling column utility is
available here:

I have read but
the proposed resolution, to add a "-o" option in bsdmainutils, doesn't
address bootiso users issue.

Please note I am writing from Ubuntu, but that has no incidence on the
scope of the present report. See also
which defers the issue to Debian maintainers.

-- System Information:
Debian Release: bullseye/sid
  APT prefers focal-updates
  APT policy: (500, 'focal-updates'), (500, 'focal-security'), (500, 'focal'), 
(100, 'focal-backports')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.4.0-31-generic (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=pt_BR.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages util-linux depends on:
ii  libaudit1      1:2.8.5-2ubuntu6
ii  libblkid1      2.34-0.1ubuntu9
ii  libc6          2.31-0ubuntu9
ii  libcap-ng0     0.7.9-2.1build1
ii  libcrypt1      1:4.4.10-10ubuntu4
ii  libmount1      2.34-0.1ubuntu9
ii  libpam0g       1.3.1-5ubuntu4
ii  libselinux1    3.0-1build2
ii  libsmartcols1  2.34-0.1ubuntu9
ii  libsystemd0    245.4-4ubuntu3
ii  libtinfo6      6.2-0ubuntu2
ii  libudev1       245.4-4ubuntu3
ii  libuuid1       2.34-0.1ubuntu9
ii  login          1:4.8.1-1ubuntu5
ii  zlib1g         1:1.2.11.dfsg-2ubuntu1

util-linux recommends no packages.

Versions of packages util-linux suggests:
ii  dosfstools          4.1-2
ii  kbd                 2.0.4-4ubuntu2
pn  util-linux-locales  <none>

-- no debconf information

Reply via email to