Source: libgig
Dear maintainer,

Please find attached a final version of this patch for the time_t
transition.  This patch is being uploaded to unstable.

Note that this adds a versioned build-dependency on dpkg-dev, to guard
against accidental backports with a wrong ABI.

Thanks!


-- System Information:
Debian Release: trixie/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 6.5.0-21-generic (SMP w/16 CPU threads; PREEMPT)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_OOT_MODULE, 
TAINT_UNSIGNED_MODULE
Locale: LANG=C, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: unable to detect
diff -Nru libgig-4.3.0~ds1/debian/changelog libgig-4.3.0~ds1/debian/changelog
--- libgig-4.3.0~ds1/debian/changelog   2021-11-01 21:47:37.000000000 +0000
+++ libgig-4.3.0~ds1/debian/changelog   2024-02-28 12:16:13.000000000 +0000
@@ -1,3 +1,10 @@
+libgig (4.3.0~ds1-2.1) unstable; urgency=medium
+
+  * Non-maintainer upload.
+  * Rename libraries for 64-bit time_t transition.  Closes: #1062312
+
+ -- Benjamin Drung <bdr...@debian.org>  Wed, 28 Feb 2024 12:16:13 +0000
+
 libgig (4.3.0~ds1-2) unstable; urgency=medium
 
   * Upload to unstable
diff -Nru libgig-4.3.0~ds1/debian/control libgig-4.3.0~ds1/debian/control
--- libgig-4.3.0~ds1/debian/control     2021-10-24 15:15:43.000000000 +0000
+++ libgig-4.3.0~ds1/debian/control     2024-02-28 12:16:13.000000000 +0000
@@ -8,7 +8,7 @@
  Alessio Treglia <ales...@debian.org>,
  Jarom√≠r MikeŇ° <mira.mi...@seznam.cz>,
  Dennis Braun <d_br...@kabelmail.de>
-Build-Depends:
+Build-Depends: dpkg-dev (>= 1.22.5),
  debhelper-compat (= 13),
  pkg-config,
  libsndfile1-dev,
@@ -27,8 +27,8 @@
 Architecture: any
 Multi-Arch: same
 Depends:
- libgig10 (= ${binary:Version}),
- libakai0 (= ${binary:Version}),
+ libgig10t64 (= ${binary:Version}),
+ libakai0t64 (= ${binary:Version}),
  ${misc:Depends}
 Description: development files for libgig
  libgig is a C++ library for loading, modifying and creating Gigasampler
@@ -47,7 +47,10 @@
  libgig. You will need this only if you intend to compile programs
  that use this library.
 
-Package: libgig10
+Package: libgig10t64
+Provides: ${t64:Provides}
+Replaces: libgig10
+Breaks: libgig10 (<< ${source:Version})
 Section: libs
 Architecture: any
 Multi-Arch: same
@@ -59,7 +62,10 @@
  .
  This package contains the shared library files.
 
-Package: libakai0
+Package: libakai0t64
+Provides: ${t64:Provides}
+Replaces: libakai0
+Breaks: libakai0 (<< ${source:Version})
 Section: libs
 Architecture: any
 Multi-Arch: same
diff -Nru libgig-4.3.0~ds1/debian/libakai0.install 
libgig-4.3.0~ds1/debian/libakai0.install
--- libgig-4.3.0~ds1/debian/libakai0.install    2021-10-24 15:15:43.000000000 
+0000
+++ libgig-4.3.0~ds1/debian/libakai0.install    1970-01-01 00:00:00.000000000 
+0000
@@ -1 +0,0 @@
-usr/lib/*/libakai.so.*
diff -Nru libgig-4.3.0~ds1/debian/libakai0t64.install 
libgig-4.3.0~ds1/debian/libakai0t64.install
--- libgig-4.3.0~ds1/debian/libakai0t64.install 1970-01-01 00:00:00.000000000 
+0000
+++ libgig-4.3.0~ds1/debian/libakai0t64.install 2021-10-24 15:15:43.000000000 
+0000
@@ -0,0 +1 @@
+usr/lib/*/libakai.so.*
diff -Nru libgig-4.3.0~ds1/debian/libakai0t64.lintian-overrides 
libgig-4.3.0~ds1/debian/libakai0t64.lintian-overrides
--- libgig-4.3.0~ds1/debian/libakai0t64.lintian-overrides       1970-01-01 
00:00:00.000000000 +0000
+++ libgig-4.3.0~ds1/debian/libakai0t64.lintian-overrides       2024-02-28 
12:16:07.000000000 +0000
@@ -0,0 +1 @@
+libakai0t64: package-name-doesnt-match-sonames libakai0
diff -Nru libgig-4.3.0~ds1/debian/libgig10.install 
libgig-4.3.0~ds1/debian/libgig10.install
--- libgig-4.3.0~ds1/debian/libgig10.install    2021-10-24 15:15:43.000000000 
+0000
+++ libgig-4.3.0~ds1/debian/libgig10.install    1970-01-01 00:00:00.000000000 
+0000
@@ -1 +0,0 @@
-usr/lib/*/libgig.so.*
diff -Nru libgig-4.3.0~ds1/debian/libgig10t64.install 
libgig-4.3.0~ds1/debian/libgig10t64.install
--- libgig-4.3.0~ds1/debian/libgig10t64.install 1970-01-01 00:00:00.000000000 
+0000
+++ libgig-4.3.0~ds1/debian/libgig10t64.install 2021-10-24 15:15:43.000000000 
+0000
@@ -0,0 +1 @@
+usr/lib/*/libgig.so.*
diff -Nru libgig-4.3.0~ds1/debian/libgig10t64.lintian-overrides 
libgig-4.3.0~ds1/debian/libgig10t64.lintian-overrides
--- libgig-4.3.0~ds1/debian/libgig10t64.lintian-overrides       1970-01-01 
00:00:00.000000000 +0000
+++ libgig-4.3.0~ds1/debian/libgig10t64.lintian-overrides       2024-02-28 
12:16:07.000000000 +0000
@@ -0,0 +1 @@
+libgig10t64: package-name-doesnt-match-sonames libgig10

Reply via email to