Source: pdns Version: 5.1.4-1 Severity: important Justification: fails autopkgtest on Debian CI infrastructure Tags: forky sid User: [email protected] Usertags: lxc
Hi, Debian CI is switching away from lxc containers in favor of incus Containers. This is motivated by security concerns from us; incus is based on lxc, but orchestrates containers substantially different: containers are not privileged (so root in the container is not uid 0 outside of it), and incus imposes a stricter isolation from the host system. pdns passes its tests under lxc, but fails under incus. The relevant part of the failure is (hopefully): > Aug 14 20:52:54 autopkgtest-incus-pqyxhx pdns_server[1638]: Unable to bind > UDP socket to '0.0.0.0:53': Address already in use > Aug 14 20:52:54 autopkgtest-incus-pqyxhx pdns_server[1638]: Fatal error: > Unable to bind to UDP socket > Aug 14 20:52:55 autopkgtest-incus-pqyxhx pdns_server[1643]: Loading > '/usr/lib/x86_64-linux-gnu/pdns/libbindbackend.so' > Aug 14 20:52:55 autopkgtest-incus-pqyxhx pdns_server[1643]: This is a > standalone pdns > Aug 14 20:52:55 autopkgtest-incus-pqyxhx pdns_server[1643]: Listening on > controlsocket in '/run/pdns/pdns.controlsocket' > Aug 14 20:52:55 autopkgtest-incus-pqyxhx pdns_server[1643]: Unable to bind > UDP socket to '0.0.0.0:53': Address already in use > Aug 14 20:52:55 autopkgtest-incus-pqyxhx pdns_server[1643]: Fatal error: > Unable to bind to UDP socket > Aug 14 20:52:56 autopkgtest-incus-pqyxhx pdns_server[1648]: Loading > '/usr/lib/x86_64-linux-gnu/pdns/libbindbackend.so' > Aug 14 20:52:56 autopkgtest-incus-pqyxhx pdns_server[1648]: This is a > standalone pdns > Aug 14 20:52:56 autopkgtest-incus-pqyxhx pdns_server[1648]: Listening on > controlsocket in '/run/pdns/pdns.controlsocket' > Aug 14 20:52:56 autopkgtest-incus-pqyxhx pdns_server[1648]: Unable to bind > UDP socket to '0.0.0.0:53': Address already in use > Aug 14 20:52:56 autopkgtest-incus-pqyxhx pdns_server[1648]: Fatal error: > Unable to bind to UDP socket > Aug 14 20:52:58 autopkgtest-incus-pqyxhx pdns_server[1653]: Loading > '/usr/lib/x86_64-linux-gnu/pdns/libbindbackend.so' > Aug 14 20:52:58 autopkgtest-incus-pqyxhx pdns_server[1653]: This is a > standalone pdns > Aug 14 20:52:58 autopkgtest-incus-pqyxhx pdns_server[1653]: Listening on > controlsocket in '/run/pdns/pdns.controlsocket' > Aug 14 20:52:58 autopkgtest-incus-pqyxhx pdns_server[1653]: Unable to bind > UDP socket to '0.0.0.0:53': Address already in use > Aug 14 20:52:58 autopkgtest-incus-pqyxhx pdns_server[1653]: Fatal error: > Unable to bind to UDP socket > Aug 14 20:52:59 autopkgtest-incus-pqyxhx pdns_server[1658]: Loading > '/usr/lib/x86_64-linux-gnu/pdns/libbindbackend.so' > Aug 14 20:52:59 autopkgtest-incus-pqyxhx pdns_server[1658]: This is a > standalone pdns > Aug 14 20:52:59 autopkgtest-incus-pqyxhx pdns_server[1658]: Listening on > controlsocket in '/run/pdns/pdns.controlsocket' > Aug 14 20:52:59 autopkgtest-incus-pqyxhx pdns_server[1658]: Unable to bind > UDP socket to '0.0.0.0:53': Address already in use > Aug 14 20:52:59 autopkgtest-incus-pqyxhx pdns_server[1658]: Fatal error: > Unable to bind to UDP socket > Aug 14 20:53:00 autopkgtest-incus-pqyxhx pdns_server[1663]: Loading > '/usr/lib/x86_64-linux-gnu/pdns/libbindbackend.so' > Aug 14 20:53:00 autopkgtest-incus-pqyxhx pdns_server[1663]: This is a > standalone pdns > Aug 14 20:53:00 autopkgtest-incus-pqyxhx pdns_server[1663]: Listening on > controlsocket in '/run/pdns/pdns.controlsocket' > Aug 14 20:53:00 autopkgtest-incus-pqyxhx pdns_server[1663]: Unable to bind > UDP socket to '0.0.0.0:53': Address already in use > Aug 14 20:53:00 autopkgtest-incus-pqyxhx pdns_server[1663]: Fatal error: > Unable to bind to UDP socket > + service pdns stop > autopkgtest [20:53:01]: test smoke-bind: -----------------------] > autopkgtest [20:53:01]: test smoke-bind: - - - - - - - - - - results - - - - > - - - - - - > smoke-bind FAIL non-zero exit status 1 The full autokpgtest logs are available at: https://ci.debian.net/experiments/8/regressions/ (please beware of pagination) Common types of failure and suggested fixes are being documented at: https://wiki.debian.org/ContinuousIntegration/LxcToIncus Note that for the time being, pdns is still being tested under lxc to avoid disturbing its testing migration test results. If you decide to add the `isolation-machine` restriction to get this package tested under qemu, please mention that explicitly when closing this bug (it's fine to do that only in the package changelog entry that closes the bug) so that we can configure your package for qemu on ci.debian.net.
signature.asc
Description: PGP signature

