Package: mariadb Version: 1:11.8.9+ds-3 Affects: mediawiki roundcube tango X-Debbugs-CC: [email protected]
While reviewing I noticed that the latest upload 1:11.8.9+ds-3 seems to trigger installation errors visible in autopkgtest results for multiple packages. Of the failures I saw, Tango has the best logging in https://ci.debian.net/packages/t/tango/testing/amd64/75882039/#S4 ... 62s Setting up tango-db (10.3.3+dfsg1-2)… 62s I: tango-db and mariadb running on the same hosts 62s Determining localhost credentials from /etc/mysql/debian.cnf: failed (no upgrade section). 62s dbconfig-common: writing config to /etc/dbconfig-common/tango-db.conf 62s Creating config file /etc/dbconfig-common/tango-db.conf with new version 62s Creating config file /var/lib/tango/.my.cnf with new version 63s checking privileges on database tango for tango@localhost: user creation needed. 63s granting access to database tango for tango@localhost: success. 63s verifying access for tango@localhost: success. 63s creating database tango: success. 63s verifying database tango exists: success. 63s populating database via sql... done. 63s dbconfig-common: flushing administrative password ... 66s autopkgtest [18:42:14]: test starter-basic: [----------------------- 66s systemd-+-Starter---2*[{Starter}] 66s |-agetty 66s |-dbus-daemon 66s |-dhcpcd-+-dhcpcd---4*[dhcpcd] 66s | `-2*[dhcpcd] 66s |-mariadbd---14*[{mariadbd}] 66s |-sshd 66s |-systemd-journal 66s `-systemd-logind 89s systemd-+-Starter---2*[{Starter}] 89s |-agetty 89s |-dbus-daemon 89s |-dhcpcd-+-dhcpcd---4*[dhcpcd] 89s | `-2*[dhcpcd] 89s |-mariadbd---14*[{mariadbd}] 89s |-sshd 89s |-systemd-journal 89s `-systemd-logind 89s Tango exception 89s Severity = ERROR 89s Error reason = API_CorbaException 89s Desc : TRANSIENT CORBA system exception: TRANSIENT_ConnectFailed 89s Origin : void Tango::Connection::connect(const std::string&) at (./lib/cpp/src/client/Connection.cpp:604) 89s 89s Tango exception 89s Severity = ERROR 89s Error reason = API_CantConnectToDatabase 89s Desc : Failed to connect to database on host ci-264-f2a855ea with port 10000 ... In the logs at https://ci.debian.net/packages/r/roundcube/testing/amd64/75882031/#S12 and https://ci.debian.net/packages/m/mediawiki/testing/amd64/75881985/#S12 there isn't an explicit error visible at all about MariaDB, but both fail to start up and connect to database, indicating that this MariaDB update indeed is the issue. Otherwise, neither Roundcube nor Mediawiki is failing in ci.debian.net otherwise. We now need to either consider reverting this change, engineer some backwards compatibility change, or review all dependent code and get it updated in other packages?

