Source: kamailio X-Debbugs-CC: [email protected] Severity: important Tags: security
Hi, The following vulnerability was published for kamailio. CVE-2026-108822[0]: | A vulnerability was detected in Kamailio up to 6.0.7/6.1.3. The | affected element is the function isup_get_calling_party of the file | src/modules/sipt/ss7_parser.c of the component sipt Module. The | manipulation of the argument length results in buffer overflow. The | attack may be performed from remote. Upgrading to version 6.0.8 and | 6.1.4 is sufficient to fix this issue. The patch is identified as | 3667bebf8d0bea07ed16218fd921d07db87aeb21. Upgrading the affected | component is advised. https://github.com/kamailio/kamailio/pull/4905 Fixed by: https://github.com/kamailio/kamailio/commit/3667bebf8d0bea07ed16218fd921d07db87aeb21 If you fix the vulnerability please also make sure to include the CVE (Common Vulnerabilities & Exposures) id in your changelog entry. For further information see: [0] https://security-tracker.debian.org/tracker/CVE-2026-108822 https://www.cve.org/CVERecord?id=CVE-2026-108822 Please adjust the affected versions in the BTS as needed.

