severity 1 normal

On Thu, Dec 27, 2007 at 03:57:39PM -0500, Tim wrote:
> no indication as to why.  I have tried shutting it down and running it
> on the command line.  I have also tried adding the -L option through
> init.d scripts.  In all cases it simply quits, whether it's run in the
> foreground or not.
-L should probably be on the command line, but in any case I have a way 
of making it work for you.

Didn't you see this sort of thing in your /var/log/lpr.log?

Dec 29 08:33:39 gonzo lpd[31741]: Setup_log: open foo.log failed - No
such file or directory
Dec 29 08:33:54 gonzo lpd[31745]: Setup_log: open /tmp/foo.log failed - Permissi
on denied

Anyway, touch the file, make sure that the user that lpd runs as is able
to write the file (most likely daemon) and you should be on your way.

Once you know where to look (and that is always half the trick) you can
see something going wrong here in strace:

31877 open("/tmp/foo2.log", O_WRONLY|O_NOCTTY|O_APPEND|O_LARGEFILE) = -1 ENOENT 
(No such file or directory)
31877 umask(077)                        = 0
31877 close(-1)   

I'd say the open has the wrong modes. It's not a very bad bug but is
surely annoying. With the instructions above you will at least be able
to look at the log files.  Remember if you are deubugging to have a look
at the -D flags too as they can provide a lot of useful information.

 - Craig
Craig Small      GnuPG:1C1B D893 1418 2AF4 45EE  95CB C76C E5AC 12CA DFA5                             csmall at :          Debian GNU/Linux, software should be Free 

with a subject of "unsubscribe". Trouble? Contact [EMAIL PROTECTED]

Reply via email to