Hello Vincent, Ben, * Vincent Lefevre wrote on Thu, Aug 07, 2008 at 04:10:47PM CEST: > On 2008-08-07 15:41:55 +0200, Ralf Wildenhues wrote: > > > So IMVHO it is very maintenance-friendly to put the statements > > together with the code that needs it as that facilitates > > copy-and-pasting the code around, for example. > > Well, the problem is that other parts of the script can still use it, > and it makes difficult to see where problem comes from.
Ah, ok. > The following > would be cleaner and completely local (so, no risks of side effects): > > require File::Copy; > File::Copy::move (... Is this also just as portable to older perl versions? If yes, then I guess a patch to change this for all instances in Autoconf and Automake would be welcome upstream. > > > (and is also there for the second "move" in the script). > > > > Where would that be? > > Line 591 in Debian's /usr/bin/autom4te. Heck, I didn't look at Debian-specific patches (upstream doesn't have this). Ben, it'd be very nice of you to pass the atomic-replace patch upstream, as you promised a mere couple of years ago. ;-) <http://thread.gmane.org/gmane.comp.sysutils.autoconf.patches/3406/focus=3420> > if ($atomic_replace && !rename("$output.tmp", "$output")) { > move ("${output}.tmp", "$output") > or fatal "cannot rename ${output}.tmp as $output: $!"; > } > > I spent some time before finding what was defining this "move"... I guess the missing 'use' here qualifies as a "limitation" in the patch then. ;-) > BTW, I did this while debugging > > http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=494112 I replied there for how that was fixed upstream. Cheers, Ralf -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of "unsubscribe". Trouble? Contact [EMAIL PROTECTED]

