On Tue, 01 Dec 2009, Joey Hess wrote: > override_dh_auto_configure: > ln -sf /usr/share/misc/config.sub . > ln -sf /usr/share/misc/config.guess . > dh_auto_configure > > override_dh_auto_clean: > dh_auto_clean > rm -f config.sub config.guess
Looks good. However, be adivised that there is a line of thought that defends doing mv config.sub config.sub.useless, and moving that back on clean. I don't subscribe to that line of thought, but some others do. > * Modify debhelper's automake buildsystem to handle the config.sub on its own. > This would probably only be suitable for a new compat level, as it risks > breaking weird packages. Another problem is that either debhelper or the > source package would need to depend on autotools-dev. > We probably don't want debhelper to have that dependency, but if the > source package forgot to add a build-depends, it would build inconsistently > and probably fai on just those autobuilders where the new config.sub is > needed. > > * Add commands with names such as dh_autotools_update and dh_autotools_clean > to autotools-dev itself. Plus a debhelper sequence addon, so users could > enable them via "dh $@ --with autotools-dev". I am fine with either, but I'd propose to change the name from *_autotools_*, to *_gnuconfig_*. The reasoning for that request is that autotools_update is not updating the autotools (it is not retooling, updating libtool, etc), it is just updating GNU config (config.sub/config.guess). -- "One disk to rule them all, One disk to find them. One disk to bring them all and in the darkness grind them. In the Land of Redmond where the shadows lie." -- The Silicon Valley Tarot Henrique Holschuh -- To UNSUBSCRIBE, email to [email protected] with a subject of "unsubscribe". Trouble? Contact [email protected]

