Your message dated Thu, 22 Sep 2016 22:49:47 +0200
with message-id <>
and subject line Re: Bug#838418: Bug#838549: libreoffice-gtk3: Fails to make 
libreoffice work
has caused the Debian Bug report #838418,
regarding libreoffice-gtk3: Font corruption - both content and dialogs
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Package: libreoffice-gtk3
Version: 1:5.2.1-3
Severity: grave
Justification: renders package unusable

Dear Maintainer,

   * What led up to the situation?

Upgrade of libreoffice. It was definitely working fine on August 16th,
then I haven't done any upgrades until this last week, so I suspect the
move from 5.2.0 to 5.2.1

   * What exactly did you do (or not do) that was effective (or

Loaded a spreadsheet, then changed a filter or preference that caused
the display to refresh.

   * What was the outcome of this action?

Cell content was illegible - sometimes just garbarge, sometimes the
characters were replaced with other (random?) characters, sometimes some
characters were emboldened.

Also dialog boxes were corrupted - such as the save/discard/cancel
buttons, and even the text in the input line.

I tried various things - deleting the user profile, running as root,
rolling back to 5.2.1-1, reinstalling fonts, nothing worked other than
uninstalling libreoffice-gtk3.

Its not a driver issue as I get the same problem on Nvidia (nouveau)
desktop and Intel laptop.

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 4.7.0-1-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages libreoffice-gtk3 depends on:
ii  dpkg                      1.18.10
ii  libatk1.0-0               2.22.0-1
ii  libc6                     2.24-3
ii  libcairo-gobject2         1.14.6-1+b1
ii  libcairo2                 1.14.6-1+b1
ii  libdbus-1-3               1.10.10-1
ii  libdbus-glib-1-2          0.108-1
ii  libgcc1                   1:6.2.0-4
ii  libgdk-pixbuf2.0-0        2.36.0-1
ii  libgl1-mesa-glx [libgl1]  12.0.3-1
ii  libglew2.0                2.0.0-3
ii  libglib2.0-0              2.49.7-1
ii  libglu1-mesa [libglu1]    9.0.0-2.1
ii  libgtk-3-0                3.21.6-1
ii  libice6                   2:1.0.9-1+b1
ii  libpango-1.0-0            1.40.2-1
ii  libpangocairo-1.0-0       1.40.2-1
ii  libreoffice-core          1:5.2.1-3
ii  libsm6                    2:1.2.2-1+b1
ii  libstdc++6                6.2.0-4
ii  libx11-6                  2:1.6.3-1
ii  libxext6                  2:1.3.3-1
ii  uno-libs3                 5.2.1-3
ii  ure                       5.2.1-3

Versions of packages libreoffice-gtk3 recommends:
ii  libreoffice-style-tango  1:5.2.1-3

Versions of packages libreoffice-gtk3 suggests:
ii  libreofficekit-data  1:5.2.1-3

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 1:5.2.2~rc2-1


On Thu, Sep 22, 2016 at 04:44:30PM +0100, Simon John wrote:
> 5.2.2 packages fix the rendering issue for me too.

Thanks. I am uploading it to unstable right now.

> So was it an upstream issue, not packaging?

Yes. Why should it have been a packaging issue? Upstream has Gtk3 in their
source, too. (just not enable in their builds ttbomk due to their old build
baseline), and the new Gtk3 broke stuff..



--- End Message ---

Reply via email to