Control: reopen 840575
Control: found 840575 0.71.0-2
Control: retitle 840575 sbuild should Depends: gnupg (>= 2.1)
Control: affects 840575 src:gnupg2

On Wed 2016-10-12 18:07:39 -0400, James Clarke wrote:
> Bugs in backported packages should not be sent to the BTS, but to
> debian-backports (CC'ed for your convenience).

While i agree with James here…

> On Wed, Oct 12, 2016 at 11:42:15PM +0200, Thomas Goirand wrote:
>> Package: sbuild
>> Version: 0.71.0-2~bpo8+1
>> Severity: grave
>> Tags: patch
>> Dear backport maintainer,
>> Since the upload of sbuild 0.71.0-2~bpo8+1 to stable backport, running
>> sbuild-update --keygen leads to this error message:
>> gpg: Invalid option "--pinentry-mode"

… it sounds like sbuild should at least have declared a versioned
dependency on gnupg (>= 2.1), when --pinentry-mode was introduced.

>> Indeed, it looks like --pinentry-mode isn't available in gnupg 1.4.18-7 which
>> is in Jessie. Since there's no backport of gnupg 2.1.x, this makes sbuild 
>> from
>> jessie-bpo completely broken, considering one need to run sbuild-update 
>> --keygen
>> to start using sbuild.

Alternately, maybe the requirement to run --keygen could be relaxed?



Attachment: signature.asc
Description: PGP signature

Reply via email to