Control: severity -1 normal
Control: tag -1 moreinfo

Hi Adam,

On 06/25/17 20:35, Adam Borowski wrote:
> Control: severity -1 serious
> Hi!
> I've tried to build this package many times (5 on armhf, 10 on amd64, once
> on arm64), and it fails every single time.
> Either Santiago's systems differ from those three of mine enough for the
> fail to be only random for him, or something else changed -- but the present
> state is that I have yet to see a successful build.
>> The bug should be reproducible with sbuild on a single CPU virtual machine,
>> provided you try enough times (as the failure happens randomly).
> All the machines I tried it on have multiple cores (4, 6 and 4,
> respectively).
I have tried to reproduce it with no success. Could you tell me more about your
setup please? I'm using the following command for testing it

set -e && for i in $(seq 10); do docker run --rm -it debian:stretch bash -c
'echo "deb-src stretch main" >
/etc/apt/sources.list.d/sources.list && apt-get update && apt-get install
eatmydata -y && eatmydata apt-get install dpkg-dev -y && apt-get source
aiocoap; eatmydata apt-get build-dep aiocoap -y && cd aiocoap-0.1+9ae36f4/ &&
dpkg-buildpackage -j$(getconf _NPROCESSORS_ONLN) -A'; done

Also I've tried using schroot and it finished correctly as well. As you can
see, I ran the command successfully 10 times, with multiple cores, with only
one core, etc. Please let me know if there is anything special on your setup to
be able to reproduce it. Or could you provide a single command to reproduce it?



Reply via email to