On Sun, Mar 04, 2018 at 07:57:11PM -0300, Antonio Terceiro wrote:
> Source: weechat
> Version: 1.9.1-1
> Severity: serious
> Justification: will FTBFS soon
> Tags: patch
> Hi,
> I am about to upload ruby-defaults to unstable, switching the default
> Ruby to ruby2.5, and ruby2.3 support will be removed right after that.
> Please consider applying the attached patch, obtained from upstream.
> Even better: please work with upstream to be able to build against the
> default ruby, instead of hardcoding a list of ruby versions. Otherwise,
> every time there is a Ruby transition, weechat will be a blocker.
> Hunting down these issues is quite time consuming.

Hi Antonio,

I agree with the need to detect Ruby and other libraries in WeeChat without
hardcoding a list of supported versions in the CMake and configure files.

I opened an issue, so this will be implemented as soon as possible:


Sébastien Helleu

web: weechat.org / flashtux.org
irc: FlashCode @ irc.freenode.net

Reply via email to