Package: wireless-regdb
Version: 2016.06.10-1
Severity: serious

When I booted Debian's package of Linux kernel 4.15 I noticed this in
my dmesg and systemd journal, it appears that the Linux kernel has
changed the name (and possibly format) of the regulatory database from
regulatory.bin to regulatory.db, making the current wireless-regdb
incompatible with Linux 4.15.

kernel: cfg80211: failed to load regulatory.db
kernel: platform regulatory.0: Direct firmware load for regulatory.db failed 
with error -2
kernel: platform regulatory.0: firmware: failed to load regulatory.db (-2)
kernel: cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
kernel: cfg80211: Loading compiled-in X.509 certificates for regulatory database

-- System Information:
Debian Release: buster/sid
  APT prefers testing-debug
  APT policy: (900, 'testing-debug'), (900, 'testing'), (800, 
'unstable-debug'), (800, 'unstable'), (790, 'buildd-unstable'), (700, 
'experimental-debug'), (700, 'experimental'), (690, 'buildd-experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 4.15.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_AU.utf8, LC_CTYPE=en_AU.utf8 (charmap=UTF-8), 
LANGUAGE=en_AU.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

wireless-regdb depends on no packages.

wireless-regdb recommends no packages.

Versions of packages wireless-regdb suggests:
ii  crda  3.18-1


Attachment: signature.asc
Description: This is a digitally signed message part

Reply via email to