Hi  all,

On 07-03-18 18:28, Michalis Kamburelis wrote:
> "2018-03-07 16:46 GMT+01:00 Graham Inggs <gin...@debian.org>:
>> On Tue, 23 Jan 2018 08:46:09 +0200 Adrian Bunk <b...@debian.org> wrote:
>>> This problem is unfortunately still present with fpc 3.0.4+dfsg-14:
>>> https://tests.reproducible-builds.org/debian/rb-pkg/unstable/amd64/transgui.html

Yes, but not for i386 and armhf. Weird.

>> This can be worked around by the following change in debian/rules:
>> -export FPCDIR=/usr/lib/fpc/${FPCDIR}
>> +export FPCDIR=/usr/lib/$(DEB_HOST_MULTIARCH)/fpc/default

@Graham, have you verified this?

> It seems that transgui is using an older "fpcmake" system (depending
> on Makefile which is auto-generated based on "Makefile.fpc" contents).
> The auto-detection is in a different place then, although it is also
> overridden by $FPCDIR environment variable.

transgui is calling fpcmake in d/rules, so it is regenerating all the
Makefiles (which is good). The failure happens DURING the call to fpcmake.

On arm64 the situation if fully different. Clean doesn't work (which
could be easily worked around in multiple ways). I.e. this should not be
blocking for building on arm64.


Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to