Your message dated Tue, 11 Feb 2020 09:58:39 +0100
with message-id <20200211085839.GA1977251@falared>
and subject line Re: [debian-mysql] Bug#951059: Bug#951059: 
mariadb-server-10.3: lc_messages=fr_FR leads to upgrade crash with apt
has caused the Debian Bug report #951059,
regarding mariadb-server-10.3: lc_messages=fr_FR leads to upgrade crash with apt
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
951059: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=951059
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: mariadb-server-10.3
Version: 1:10.3.22-0+deb10u1
Severity: grave
Tags: l10n d-i
Justification: renders package unusable

Dear Maintainer,

when upgrading to latest stable release of mariadb-server, with apt-get upgrade,
the installation failed, the server does not start again, and I find on syslog:

mariadb-server-10.3.postinst[23690]: 2020-02-10 14:36:06 0 [ERROR] Aborting
mariadb-server-10.3.postinst[23690]: Installation of system tables failed!  
Examine the logs in
mariadb-server-10.3.postinst[23690]: /var/lib/mysql for more information.
mariadb-server-10.3.postinst[23690]:
mariadb-server-10.3.postinst[23690]: The problem could be conflicting 
information in an external
mariadb-server-10.3.postinst[23690]: my.cnf files. You can ignore these by 
doing:
mariadb-server-10.3.postinst[23690]:
mariadb-server-10.3.postinst[23690]:     shell> /usr/bin/mysql_install_db 
--defaults-file=~/.my.cnf
mariadb-server-10.3.postinst[23690]:
mariadb-server-10.3.postinst[23690]: You can also try to start the mysqld 
daemon with:
mariadb-server-10.3.postinst[23690]:
mariadb-server-10.3.postinst[23690]:     shell> /usr/sbin/mysqld 
--skip-grant-tables --general-log &
mariadb-server-10.3.postinst[23690]:
mariadb-server-10.3.postinst[23690]: and use the command line tool 
/usr/bin/mysql
mariadb-server-10.3.postinst[23690]: to connect to the mysql database and look 
at the grant tables:
mariadb-server-10.3.postinst[23690]:
mariadb-server-10.3.postinst[23690]:     shell> /usr/bin/mysql -u root mysql
mariadb-server-10.3.postinst[23690]:     mysql> show tables;
mariadb-server-10.3.postinst[23690]:
mariadb-server-10.3.postinst[23690]: Try 'mysqld --help' if you have problems 
with paths.  Using
mariadb-server-10.3.postinst[23690]: --general-log gives you a log in 
/var/lib/mysql that may be helpful.
mariadb-server-10.3.postinst[23690]:
mariadb-server-10.3.postinst[23690]: The latest information about 
mysql_install_db is available at
mariadb-server-10.3.postinst[23690]: 
https://mariadb.com/kb/en/installing-system-tables-mysql_install_db
mariadb-server-10.3.postinst[23690]: You can find the latest source at 
https://downloads.mariadb.org and
mariadb-server-10.3.postinst[23690]: the maria-discuss email list at 
https://launchpad.net/~maria-discuss
mariadb-server-10.3.postinst[23690]:
mariadb-server-10.3.postinst[23690]: Please check all of the above before 
submitting a bug report
mariadb-server-10.3.postinst[23690]: at http://mariadb.org/jira
...
mysqld[23967]: 2020-02-10 14:36:07 0 [ERROR] Aborting
systemd[1]: mariadb.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: mariadb.service: Failed with result 'exit-code'.
systemd[1]: Failed to start MariaDB 10.3.22 database server.

No error written in /var/log/mysql/error.log
This is just that the upgrade script failed to complete.

It crashed my 3 servers with MariaDB on it.
After searching for a while (doing the 'apt-get upgrade' again and again, 
restoring my VMs snapshots each time),
I found that removing the following line in my config before doing the upgrade 
resolved the issue:
lc_messages = fr_FR

This is the only way I managed to fix the error.

I also tested the 'testing' version of the package, with the same error at the 
end.


Best regards,
Jeremie LEGRAND


-- System Information:
Debian Release: 10.3
  APT prefers stable
  APT policy: (990, 'stable'), (500, 'stable-updates')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-8-amd64 (SMP w/3 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8), 
LANGUAGE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages mariadb-server-10.3 depends on:
ii  adduser                   3.118
ii  debconf [debconf-2.0]     1.5.71
ii  galera-3                  25.3.25-2
ii  gawk                      1:4.2.1+dfsg-1
ii  iproute2                  4.20.0-2
ii  libc6                     2.28-10
ii  libdbi-perl               1.642-1+b1
ii  libgnutls30               3.6.7-4+deb10u2
ii  libpam0g                  1.3.1-5
ii  libstdc++6                8.3.0-6
ii  lsb-base                  10.2019051400
ii  lsof                      4.91+dfsg-1
ii  mariadb-client-10.3       1:10.3.22-0+deb10u1
ii  mariadb-common            1:10.3.22-0+deb10u1
ii  mariadb-server-core-10.3  1:10.3.22-0+deb10u1
ii  passwd                    1:4.5-1.1
ii  perl                      5.28.1-6
ii  psmisc                    23.2-1
ii  rsync                     3.1.3-6
ii  socat                     1.7.3.2-2
ii  zlib1g                    1:1.2.11.dfsg-1

Versions of packages mariadb-server-10.3 recommends:
ii  libhtml-template-perl  2.97-1

Versions of packages mariadb-server-10.3 suggests:
ii  bsd-mailx [mailx]  8.1.2-0.20180807cvs-1
pn  mariadb-test       <none>
pn  netcat-openbsd     <none>
pn  tinyca             <none>

-- debconf information:
  mariadb-server-10.3/old_data_directory_saved:
  mariadb-server-10.3/postrm_remove_databases: false
  mariadb-server-10.3/nis_warning:

--- End Message ---
--- Begin Message ---
Bug reported upstream:
https://jira.mariadb.org/browse/MDEV-21586

Introduced in:
https://jira.mariadb.org/browse/MDEV-11345

Fixed in 10.3.23.

Attachment: signature.asc
Description: PGP signature


--- End Message ---

Reply via email to