On 21/09/16 20:54, Emmanuel Kasper wrote:
can you login in the box via VirtualGui as vagrant user ( pw vagrant )

then do as root

echo "pre-up sleep 2" >> /etc/network/interfaces

shutdown the machine

and see if "vagrant up" this time works

Hello Emmanuel!
Unfortunately I have the same result:

$ vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Checking if box 'debian/jessie64' is up to date...
==> default: Clearing any previously set forwarded ports...
==> default: Fixed port collision for 22 => 2222. Now on port 2200.
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
    default: Adapter 1: nat
==> default: Forwarding ports...
    default: 22 (guest) => 2200 (host) (adapter 1)
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
    default: SSH address: 127.0.0.1:2200
    default: SSH username: vagrant
    default: SSH auth method: private key
Timed out while waiting for the machine to boot. This means that
Vagrant was unable to communicate with the guest machine within
the configured ("config.vm.boot_timeout" value) time period.


Here is the /etc/network/interfaces file after last command*:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp
pre-up sleep 2


I also checked the same scenario with auto eth0 instead of allow-hotplug eth0 and it didn't change anything.


Following this reasoning I also launched /etc/init.d/networking status to see:
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
..
No DHCPOFFERS received.
No working leases in persistent database - sleeping.


To be sure that the problem is with this particular 8.6.0 box version I also tested the same commands as in original thread on another computer with little older software - OS X El Capitan 10.11.6, VirtualBox 4.3.10 r101610 and Vagrant 1.8.4 - the same result.



* I had to retype the text by hand so hopefully I did that without errors.

Reply via email to