On Tue, Oct 18, 2016 at 03:36:56PM +0800, SZ Lin (林上智) wrote:
> Although these packages are not API-compatible, they are using the
> same installation path and file name; therefore, I think "Conflict:"
> section is needed.

The problem with this is that this prevents our users from having both
of them installed. These are Python libraries. Imagine a situation
where a user needs two applications and they depend on these two
libraries, one each? Having the libraries conflict with each other
means the user can't have both applications installed at the same
time. That would be unfortunate.

I don't have a solution for this. The ideal solution would be for one
or both upstream developers to rename their library. However, that's
only ideal in the long run, since it requires every program that uses
the libraries to be updated to use the new name.

I want to build worthwhile things that might last. --joeyh

Attachment: signature.asc
Description: PGP signature

Reply via email to