Package: g++-6
Version: 6.3.0-18+rpi1+deb9u1
Severity: important

Dear Maintainer,


   * What led up to the situation?
I have been using raspicam on a raspberry PI 3 B+.  doing some development work.
recompiling a working program begain giving me invalid strtab errors.
   * What exactly did you do (or not do) that was effective (or
     ineffective)?
Tried rebuilding raspicam from scratch from the archive files.
ran cmake, no issue, ran make, got the errors on the original source code.
This is did not happen during the intial install.
   * What was the outcome of this action?
Now working programs are broken and give segmentation faults.
   * What outcome did you expect instead?
for the make and make install to go without errors.


-- System Information:
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 9.8 (stretch)
Release:        9.8
Codename:       stretch
Architecture: armv7l

Kernel: Linux 4.14.79-v7+ (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages g++-6 depends on:
ii  gcc-6            6.3.0-18+rpi1+deb9u1
ii  gcc-6-base       6.3.0-18+rpi1+deb9u1
ii  libc6            2.24-11+deb9u4
ii  libgmp10         2:6.1.2+dfsg-1
ii  libisl15         0.18-1
ii  libmpc3          1.0.3-1
ii  libmpfr4         3.1.5-1
ii  libstdc++-6-dev  6.3.0-18+rpi1+deb9u1
ii  zlib1g           1:1.2.8.dfsg-5

g++-6 recommends no packages.

Versions of packages g++-6 suggests:
pn  gcc-6-doc         <none>
pn  libstdc++6-6-dbg  <none>

-- no debconf information

Reply via email to